易语言GetUserNameA获取系统当前用户名

取用户名GetUserNameA

注意:在易语言中,第二参数nSize需要选中传址

  1. .版本 2
    
  2.  
  3. .DLL命令 取用户名, 逻辑型, "advapi32", "GetUserNameA"
    
  4.     .参数 lpBuffer, 文本型, , 0
    
  5.     .参数 nSize, 整数型, 传址, 255

参数 类型及说明
lpBuffer String,一个字串缓冲区,预先初始化成由nSize指定的长度。它将用于容纳用户名,是获取名称缓冲区。
nSize Long,初始化成lpBuffer的长度。返回以后,它会包含载入lpBuffer的字符数量 ,是缓冲区的大小和返回帐号的大小。

易语言调用

  1. .版本 2
    
  2. .支持库 spec
    
  3.  
  4. .子程序 _按钮1_被单击
    
  5. .局部变量 用户名, 文本型
    
  6.  
  7.  
  8. 用户名 = 取空白文本 (255)
    
  9. 取用户名 (用户名, 255)
    
  10. 调试输出 (用户名)

API函数详解:GetUserName函数

Windows API函数 Visual Basic 语法格式声明
Declare Function GetUserName Lib "advapi32.dll" Alias "GetUserNameA" (ByVal lpBuffer As String, nSize As Long) As Long
Windows API函数功能说明
取得当前用户的名字
Windows API函数出口返回值
Long,TRUE(非零)表示成功,否则返回零。会设置GetLastError
Windows API函数入口参数表
Windows API函数入口参数 类型及说明
lpBuffer String,一个字串缓冲区,预先初始化成由nSize指定的长度。它将用于容纳用户名
nSize Long,初始化成lpBuffer的长度。返回以后,它会包含载入lpBuffer的字符数量
示例
Dim s$, cnt&, dl&
cnt& = 199
s$ = String$(200,0)
dl& = GetUserName(s$, cnt)
Debug.Print Left$(s$, cnt); cnt
上页:API函数详解:XFORM函数 下页:API函数详解:AbortPath函数


发布日期:

所属分类: 易语言 标签: