511遇见易语言多线程大漠多线程-7启动线程传递参数自定义数据

L-7-线程传参自定义数据

• 1、自定义数据类型
• 2、传递自定义数据类型的指针
• 3、把数据内存指针转换为新数据内存指针
• 4、赋给新的自定义数据变量
课程源码:

 
.子程序 子程序1
.参数 a, 整数型
.局部变量 C, 自定义数据
 
置换数据指针 (a, 取变量地址 (C))
释放内存 (a)
调试输出 (C.文本型)
信息框 (到文本 (C.整数型) + C.文本型, 0, , )
 
 
.子程序 置换数据指针, , 公开
.参数 参_原数据内存地址, 整数型
.参数 参_新数据内存地址, 整数型
 
写到内存 (取字节集数据 (指针到字节集 (参_原数据内存地址, 4), #整数型, ), 参_新数据内存地址, 4)
' 1-设置为静态变量
' 2-程序集变量
' 3-全局变量
' 4-不能是局部变量


发布日期:

所属分类: 后端 标签: