易语言通过全局键盘鼠标钩子编写屏保锁屏软件

画板输入框界面初始化源码:

.版本 2
时钟1.时钟周期 = 1
 
宽度 = 取屏幕宽度 ()
高度 = 取屏幕高度 ()
 
左边 = 0
顶边 = 0
边框 = 0
位置 = 0
总在最前 = 真
 
画板1.左边 = 0
画板1.顶边 = 0
画板1.宽度 = 取屏幕宽度 ()
画板1.高度 = 取屏幕高度 ()
 
编辑框1.左边 = 取屏幕宽度 () ÷ 2144
编辑框1.顶边 = 取屏幕高度 () ÷ 2
 
按钮1.左边 = 取屏幕宽度 () ÷ 2
按钮1.顶边 = 取屏幕高度 () ÷ 2

安装鼠标和键盘钩子

.版本 2
 
键盘钩子 = SetWindowsHookExA (13, &键盘回调, GetModuleHandleA (0), 0)
鼠标钩子 = SetWindowsHookExA (14, &鼠标钩子回调, GetModuleHandleA (0), 0)

键盘钩子回调函数

.版本 2
 
.子程序 键盘回调, 整数型
.参数 参数一, 整数型
.参数 参数二, 整数型
.参数 参数三, 整数型
.局部变量 键值, 整数型
 
键值 = 取字节集数据 (指针到字节集 (参数三, 1), 3, )
.判断开始 (键值 ≥ 48 且 键值 ≤ 57)
    返回 (0)
.默认
    返回 (1)
.判断结束
返回 (CallNextHookEx (键盘钩子, 参数一, 参数二, 参数三))

鼠标钩子回调函数

.版本 2
 
.子程序 键盘回调, 整数型
.参数 参数一, 整数型
.参数 参数二, 整数型
.参数 参数三, 整数型
.局部变量 键值, 整数型
 
键值 = 取字节集数据 (指针到字节集 (参数三, 1), 3, )
.判断开始 (键值 ≥ 48 且 键值 ≤ 57)
    返回 (0)
.默认
    返回 (1)
.判断结束
返回 (CallNextHookEx (键盘钩子, 参数一, 参数二, 参数三))

时钟周期事件,完成星空效果

.版本 2
 
.子程序 _时钟1_周期事件
.局部变量 color
.局部变量 x
.局部变量 y
 
置随机数种子 ()
color = 取颜色值 (取随机数 (0, ), 取随机数 (0, ), 取随机数 (0, ))
x = 取随机数 (0, 画板1.宽度)
y = 取随机数 (0, 画板1.高度)
 
画板1.画点 (x, y, color)

密码验证

.版本 2
 
.子程序 _按钮1_被单击
 
.判断开始 (编辑框1.内容 = “123456)
    销毁 ()
    结束 ()

发布日期:

所属分类: 易语言 标签: