易语言教程取字节集长度取字节集数据到字节集

字节

字节(Byte):字节是通过网络传输信息(或在硬盘或内存中存储信息)的单位。
一个英文字母(不分大小写)占一个字节的空间,一个中文汉字占两个字节的空间.符号:英文标点占一个字节,中文标点占两个字节.
字节也叫Byte,是计算机数据的基本存储单位。另一个相关的概念叫位(bit),1Byte=8bit一般来说,一个汉字占两个字节,可见Byte是一个非常小的存储单位。通常我们更常用的是KB、MB、GB,他们之间的换算是1KB=1024Byte,1MB=1024KB,1GB=1024MB。

字节集

字节集是字节的集合,在其他编程语言里是二进制文件,也就是bin。一个文件、一个图片、一个MP3音乐等等,都是字节集。
字节集,简单地说就是由字节组成的数组,其成员都是字节,每个字节转成数值只能在0到255之间

取字节集长度

调用格式: 〈整数型〉 取字节集长度 (字节集 字节集数据) - 系统核心支持库->字节集操作
英文名称:BinLen
取字节集型数据的长度。本命令为初级命令。
参数<1>的名称为“字节集数据”,类型为“字节集(bin)”。参数值指定欲检查其长度的字节集数据。

操作系统需求: Windows、Linux

到字节集

调用格式: 〈字节集〉 到字节集 (通用型数组/非数组 欲转换为字节集的数据) - 系统核心支持库->字节集操作
英文名称:ToBin
将指定数据转换为字节集后返回转换结果。本命令为初级命令。
参数<1>的名称为“欲转换为字节集的数据”,类型为“通用型(all)”,提供参数数据时可以同时提供数组或非数组数据。参数值只能为基本数据类型数据或数值型数组。

操作系统需求: Windows、Linux

取字节集数据

调用格式: 〈通用型〉 取字节集数据 (字节集 欲取出其中数据的字节集,整数型 欲取出数据的类型,[整数型 起始索引位置]) - 系统核心支持库->字节集操作
英文名称:GetBinElement
取出字节集中指定位置指定数据类型的数据。本命令为初级命令。
参数<1>的名称为“欲取出其中数据的字节集”,类型为“字节集(bin)”。
参数<2>的名称为“欲取出数据的类型”,类型为“整数型(int)”。参数值可以为以下常量: 1、#字节型; 2、#短整数型; 3、#整数型; 4、#长整数型; 5、#小数型; 6、#双精度小数型; 7、#逻辑型; 8、#日期时间型; 9、#子程序指针型; 10、#文本型。转换后的数据将自动进行有效性校验及转换处理。
参数<3>的名称为“起始索引位置”,类型为“整数型(int)”,可以被省略。指定从字节集的什么地方开始取数据,索引值从1开始。如果被省略,默认为数值1。如果为本参数提供一个整数型变量,则命令执行后将自动修改该变量内容,将其索引值移动到下一个读入位置。如果移动后到达字节集的末尾,将修改该变量的内容为-1。

操作系统需求: Windows、Linux

视频教程源码

.版本 2

.程序集 窗口程序集_启动窗口

.子程序 _按钮1_被单击, , , 取字节集长度
.局部变量 图片长度, 整数型

图片长度 = 取字节集长度 (图片框1.图片)
信息框 (“图片框图片的大小为: ” + 到文本 (图片长度) + “字节”, 0, , )

.子程序 _按钮2_被单击, , , 到字节集
.局部变量 文本, 文本型
.局部变量 整数, 整数型
.局部变量 短整数, 短整数型

文本 = “369”
整数 = 369
短整数 = 369
编辑框1.内容 = 到文本 (取字节集长度 (到字节集 (文本)))
编辑框2.内容 = 到文本 (取字节集长度 (到字节集 (整数)))
编辑框3.内容 = 到文本 (取字节集长度 (到字节集 (短整数)))

.子程序 _按钮3_被单击, , , 取字节集数据

信息框 (“字节集转换后的结果为: ” + 取字节集数据 ({ 53, 49, 49, 211, 246, 188, 251 }, #文本型, ), 0, , )

.子程序 _按钮4_被单击, , , 读入文件
.局部变量 返回字节集变量, 字节集

.如果真 (通用对话框1.打开 ())
返回字节集变量 = 读入文件 (通用对话框1.文件名) ' 读入文件直接把文件以字节集的形式读入
' 这里取字节集数据等价于 到文本(返回字节集变量)
编辑框4.内容 = 取字节集数据 (返回字节集变量, #文本型, )

.如果真结束


发布日期:

所属分类: 易语言 标签: