易语言乐玩插件置图片密码和枚举图片卡屏判断

乐玩插件模块源码

.版本 2

.子程序 SetPicPwd, 整数型, 公开
.参数 pwd, 文本型

返回 (obj.数值方法 (“SetPicPwd”, pwd))

.子程序 MatchPicName, 文本型, 公开
.参数 pic_name, 文本型

返回 (obj.文本方法 (“MatchPicName”, pic_name))

.子程序 IsDisplayDead, 整数型, 公开, 0 : 没有卡屏1 : 卡屏
.参数 x1
.参数 y1
.参数 x2
.参数 y2
.参数 timeout, , , 单位 :秒

返回 (obj.数值方法 (“IsDisplayDead”, x1, y1, x2, y2, timeout))

乐玩模块调用测试源码:

.版本 2
.支持库 spec
.支持库 EThread

.子程序 _按钮13_被单击, , , SetPicPwd
.局部变量 ret, 文本型
.局部变量 ss, 文本型, , "0"
.局部变量 sss, 文本型, , "0"
.局部变量 i, 整数型
.局部变量 id, 整数型
.局部变量 x
.局部变量 y

l.SetPicPwd (“123”)
延时 (100)
ret = l.FindPicEx (0, 0, 2000, 2000, “2.bmp|1.bmp”, “000000”, 0.95, 0)
调试输出 (ret)
' “1,602,5|2,754,175”
.如果真 (取文本长度 (ret) > 0)
ss = 分割文本 (ret, “|”, )
.计次循环首 (取数组成员数 (ss), i)
sss = 分割文本 (ss [i], “,”, )
id = 到整数 (sss [1])
x = 到整数 (sss [2])
y = 到整数 (sss [3])
延时 (100)
l.MoveTo (x, y)
延时 (100)
l.LeftDoubleClick ()
延时 (100)
.计次循环尾 ()

.如果真结束
.子程序 _按钮14_被单击, , , MatchPicName
.局部变量 ret, 文本型
.局部变量 ss, 文本型, , "0"
.局部变量 sss, 文本型, , "0"
.局部变量 i, 整数型
.局部变量 id, 整数型
.局部变量 x
.局部变量 y
.局部变量 all_pic, 文本型
.局部变量 pic_mame, 文本型

l.SetPicPwd (“123”)
延时 (100)
all_pic = “*.bmp”
pic_mame = l.MatchPicName (all_pic)
调试输出 (pic_mame)

ret = l.FindPicEx (0, 0, 2000, 2000, pic_mame, “000000”, 0.95, 0)
调试输出 (ret)
' “1,602,5|2,754,175”
.如果真 (取文本长度 (ret) > 0)
ss = 分割文本 (ret, “|”, )
.计次循环首 (取数组成员数 (ss), i)
sss = 分割文本 (ss [i], “,”, )
id = 到整数 (sss [1])
x = 到整数 (sss [2])
y = 到整数 (sss [3])
延时 (100)
l.MoveTo (x, y)
延时 (100)
l.LeftDoubleClick ()
延时 (100)
.计次循环尾 ()

.如果真结束
.子程序 _按钮15_被单击, , , IsDisplayDead

时钟1.时钟周期 = 3000
.子程序 是否卡屏
.局部变量 ret, 整数型

' 判断卡屏
' 判断跑路是否停止
' 判断是否到达目的地
' 乐玩和大漠都有这大命令,最后一个时间参数,这里是秒

ret = l.IsDisplayDead (698, 41, 774, 112, 2)
.判断开始 (ret = 0)
标题 = “---------没有卡屏!”
.判断 (ret = 1)
标题 = “-------- 卡屏了!”
.默认

.判断结束

.子程序 _时钟1_周期事件

启动线程 (&是否卡屏, , )

教程下载:

链接:https://pan.baidu.com/s/1Z-GwQ84X7iccpK3NngsPZQ

提取码:加QQ群:521068947 群文件下载


发布日期:

所属分类: 易语言 标签: