易语言鼠标滚轮与纵向滚动条联动

一、首先

启动窗口创建完毕,要让纵向滚动条获取焦点

纵向滚动条1.获取焦点 ()

二、设置事件

.版本 2
.子程序 _纵向滚动条1_滚轮被滚动, 逻辑型
.参数 滚动距离, 整数型
.参数 功能键状态, 整数型
.如果 (滚动距离 > 0)
    纵向滚动条1.位置 = 纵向滚动条1.位置 - 2
    返回 ()
.否则
    纵向滚动条1.位置 = 纵向滚动条1.位置 + 2
    返回 ()
.如果结束

三、易语言纵向滚动条怎样实现滚轮滚动

.版本 2
 
.子程序 __启动窗口_滚轮被滚动, 逻辑型
.参数 滚动距离, 整数型
.参数 功能键状态, 整数型
 
纵向滚动条1.位置 = 纵向滚动条1.位置 - 滚动距离

发布日期:

所属分类: 易语言 标签:


下一篇:

没有了,已经是最新文章