易语言PathIsFileSpecA路径是否文件格式

路径是否文件格式PathIsFileSpecA

.版本 2
 
.DLL命令 路径是否文件格式_, 整数型, "shlwapi.dll", "PathIsFileSpecA"
    .参数 路径文本, 文本型, , pszPath

易语言调用

.版本 2

.程序集 窗口程序集_启动窗口

.子程序 __启动窗口_创建完毕

' PathIsFileSpecA的作用是
' given a path or file, determines
' if the string is a file or path.
' The function searches a path for
' any path delimiting characters
' (for example, ':' or '\' ). If
' there are no path delimiting
' characters present, the path is
' considered to be a File Spec path.
标签_显示1.标题 = “\\workstation\javatools\somefile.txt”
标签_显示2.标题 = “somefile.txt”
标签_显示3.标题 = “\\192.168.1.100\d$\javatools\”
标签_显示4.标题 = “http://www.microsoft.com/ms.htm”
标签_显示5.标题 = “www.microsoft.com”

.子程序 _按钮_路径是否文件格式_被单击

.判断开始 (路径是否文件格式_ (标签_显示1.标题) ≠ 0)
编辑框_效果1.内容 = “是”
.默认
编辑框_效果1.内容 = “否”
.判断结束
.判断开始 (路径是否文件格式_ (标签_显示2.标题) ≠ 0)
编辑框_效果2.内容 = “是”
.默认
编辑框_效果2.内容 = “否”
.判断结束
.判断开始 (路径是否文件格式_ (标签_显示3.标题) ≠ 0)
编辑框_效果3.内容 = “是”
.默认
编辑框_效果3.内容 = “否”
.判断结束
.判断开始 (路径是否文件格式_ (标签_显示4.标题) ≠ 0)
编辑框_效果4.内容 = “是”
.默认
编辑框_效果4.内容 = “否”
.判断结束
.判断开始 (路径是否文件格式_ (标签_显示5.标题) ≠ 0)
编辑框_效果5.内容 = “是”
.默认
编辑框_效果5.内容 = “否”
.判断结束


发布日期:

所属分类: 易语言 标签: