易语言PathUndecorateA去除路径中的修饰

修饰路径PathUndecorateA

.版本 2
 
.DLL命令 修饰路径_, , "shlwapi.dll", "PathUndecorateA"
    .参数 路径文本, 文本型, , pszPath

xxx

Initial String Undecorated String
C:\Path\File[5].txt C:\Path\File.txt
C:\Path\File[12] C:\Path\File
C:\Path\File.txt C:\Path\File.txt
C:\Path\[3].txt C:\Path\[3].txt

.版本 2
 
.程序集 窗口程序集_启动窗口
 
.子程序 __启动窗口_创建完毕
 
' PathUndecorateA的作用是修饰文本。
' 例子:
' C:\Path\File[5].txt  返回       C:\Path\File.txt
' C:\Path\File[12]     返回       C:\Path\File
' C:\Path\File.txt     返回       C:\Path\File.txt
' C:\Path\[3].txt      返回       C:\Path\[3].txt
 
.子程序 _按钮_修饰路径_被单击
.局部变量 局部_路径文本, 文本型
 
局部_路径文本 = 编辑框_路径文本.内容
修饰路径_ (局部_路径文本)
编辑框_返回.内容 = 局部_路径文本

发布日期:

所属分类: 易语言 标签: