易语言PathIsPrefixA径文本串是否归属指定盘符

路径是否属于驱动器PathIsPrefixA

.版本 2
 
.DLL命令 路径是否属于驱动器_, 逻辑型, "shlwapi.dll", "PathIsPrefixA", , 属于返回真,不属于返回假
    .参数 驱动器, 文本型, , pszPrefix
    .参数 路径文本, 文本型, , pszPath

易语言调用

.版本 2

.程序集 窗口程序集_启动窗口

.子程序 __启动窗口_创建完毕
.局部变量 局部_循环变量, 整数型

' PathIsPrefixA的作用是检查路径文本串是否归属指定盘符。
' 是,返回真,不是,返回假。
.变量循环首 (65, 65 + 25, 1, 局部_循环变量)
组合框_盘符.加入项目 (字符 (局部_循环变量) + “:\”, )
.变量循环尾 ()
组合框_盘符.现行选中项 = 0

.子程序 _按钮_路径是否属于驱动器_被单击

.判断开始 (路径是否属于驱动器_ (组合框_盘符.取项目文本 (组合框_盘符.现行选中项), 编辑框_路径文本.内容) = 真)
编辑框_运行结果.内容 = 编辑框_路径文本.内容 + “属于” + 取文本左边 (组合框_盘符.取项目文本 (组合框_盘符.现行选中项), 1) + “盘”
.默认
编辑框_运行结果.内容 = 编辑框_路径文本.内容 + “不属于” + 取文本左边 (组合框_盘符.取项目文本 (组合框_盘符.现行选中项), 1) + “盘”
.判断结束
置随机数种子 ()
编辑框_路径文本.内容 = 子文本替换 (编辑框_路径文本.内容, 取文本左边 (编辑框_路径文本.内容, 1), 字符 (取随机数 (97, 97 + 25)), , 1, 真)


发布日期:

所属分类: 易语言 标签: