511遇见易语言多线程大漠多线程-33大漠多线程模板-3UI更新

大漠多线程模板源码:

.版本 2
.支持库 iext

.子程序 UI_更新, , , 用来更新窗口的超级列表框相关线程信息
.参数 主序号, 整数型
.参数 操作, 整数型
.局部变量 列表索引, 整数型

' 增加
.如果真 (操作 = #UI_增加)
列表索引 = 窗口列表.插入表项 (, , , , , )

窗口列表.置标题 (列表索引, 0, 到文本 (线程信息 [主序号].窗口句柄)) ' 窗口句柄
窗口列表.置标题 (列表索引, 0, 到文本 (线程信息 [主序号].进程PID)) ' pid
窗口列表.置标题 (列表索引, 0, 到文本 (主序号)) ' 主序号
窗口列表.置标题 (列表索引, 0, 到文本 (主序号 + MaxHwnd)) ' 副序号
UI_更新 (主序号, #UI_更新)

.如果真结束
' 删除
.如果真 (操作 = #UI_删除)
列表索引 = 取列表索引号 (主序号)
.如果真 (列表索引 = -1)
返回 (-1)
.如果真结束
窗口列表.删除表项 (列表索引)
窗口列表.刷新显示 ()
返回 ()
.如果真结束

' 更新
.如果真 (操作 = #UI_更新)
列表索引 = 取列表索引号 (主序号)
.如果真 (列表索引 = -1)
返回 (-1)
.如果真结束

' 先更新主线程
窗口列表.置标题 (列表索引, 4, 线程状态转文本 (线程信息 [主序号].线程状态)) ' 主线程状态
窗口列表.置标题 (列表索引, 6, 线程信息 [主序号].任务状态) ' 主线程任务状态

' 再更副主线程
窗口列表.置标题 (列表索引, 5, 线程状态转文本 (线程信息 [主序号 + MaxHwnd].线程状态)) ' 副线程状态
窗口列表.置标题 (列表索引, 7, 线程信息 [主序号 + MaxHwnd].异常状态) ' 异常状态
窗口列表.刷新显示 ()
返回 ()

.如果真结束

.子程序 线程状态转文本, 文本型
.参数 线程状态, 整数型

.如果真 (线程状态 = #线程状态_未启动)
返回 (“未启动”)
.如果真结束

.如果真 (线程状态 = #线程状态_正在启动)
返回 (“正在启动”)
.如果真结束

.如果真 (线程状态 = #线程状态_正在运行)
返回 (“正在运行”)
.如果真结束

.如果真 (线程状态 = #线程状态_正在暂停)
返回 (“正在暂停”)
.如果真结束

.如果真 (线程状态 = #线程状态_暂停)
返回 (“暂停”)
.如果真结束

.如果真 (线程状态 = #线程状态_正在恢复)
返回 (“正在恢复”)
.如果真结束

.如果真 (线程状态 = #线程状态_正在停止)
返回 (“正在停止”)
.如果真结束

日志输出 (“未定义的线程状态” + 到文本 (线程状态))
返回 (“未定义”)


发布日期:

所属分类: 易语言 标签: