易语言应用接口支持库MySql支持库查找记录

查找记录

查找记录 命令 操作系统支持:Windows 所属类别:MySql支持库

查找满足条件的记录,返回记录集句柄.注意执行这条语句后不需要再执行 返回记录集 命令。

语法: 整数型 查找记录 (MySql句柄,表名,字段名,查找条件,排序条件)

参数名 描述
MySql句柄 必需的;整数型。调用 连接MySql 的返回值。
表名 必需的;文本型。您要查询的表的名称。
字段名 必需的;文本型。您要查询的表中字段的名称,可以使用逗号连接多个字段,如果为*号则表示查询所有字段. 例子1 单个字段 name 例子2 多个字段 name,email,id 例子3 所有字段 *。
查找条件 必需的;文本型。您要查询的条件.例子1 如果您要查找name的值为jack的记录 name='jack' 例子2 如果您要查找name的值为jack并且id的值为2的记录 name='jack' and id=2 例子3 如果您要查找name的值为jack或者id的值为2的记录 name='jack' or id=2。
排序条件 必需的;文本型。排序的条件 排序条件,ASC为升序,DESC为降序 例子 要对name字段进行降序排序 name DESC 。

例程截图

根据查找条件查找纪录,查找条件返回记录集句柄,根据这个句柄操作查找的结果,不需要在使用取记录集来取得记录集句柄了。

511遇见

例程源码

.版本 2
.支持库 mysql
.支持库 iext

.子程序 _查找记录按钮_被单击
.局部变量 语句, 文本型
.局部变量 name字段, 文本型
.局部变量 索引, 整数型
.局部变量 number字段, 文本型
.局部变量 子记录集句柄, 整数型

.如果真 (输入框 (“SQL语句,我们这里在第一个字段name中查找”, , , 语句, ) = 真)
子记录集句柄 = 查找记录 (MySql句柄, “test”, “name”, 语句, “ASC”)
.计次循环首 (取记录集行数 (子记录集句柄), )
读字段值 (子记录集句柄, “name”, name字段)
索引 = 数据库超级列表框.插入表项 (, name字段, , , , )
读字段值 (子记录集句柄, 2, number字段)
数据库超级列表框.置标题 (索引, 1, number字段)
到下一行 (子记录集句柄)
.计次循环尾 ()
信息列表框.加入项目 (语句 + “执行完毕!”, )
信息列表框.现行选中项 = 信息列表框.取项目数 () - 1


发布日期:

所属分类: 易语言 标签: