易语言输入法注入dll到游戏进程

载入DLL

dll句柄 = LoadLibraryA (编辑框1.内容)

线程启动

为了对注入的DLL的控制,我们在dll里并没有直接调用函数,而采用线程调用,这样可以多次重复调用。

.版本 2
.支持库 spec
.支持库 EThread
 
.局部变量 函数地址
.局部变量 内存地址
.局部变量 线程ID
.局部变量 线程句柄
 
函数地址 = GetProcAddress (dll句柄, 编辑框3.内容)
内存地址 = 申请内存 (取文本长度 (编辑框3.内容), )
写到内存 (编辑框3.内容, 内存地址, )
线程句柄 = CreateThread (0, 0, 函数地址, 内存地址, 0, 线程ID)
.如果真 (等待线程 (线程句柄, 100))
    关闭线程句柄 (线程句柄)
    释放内存 (内存地址)
.如果真结束

教程获取下载:


发布日期:

所属分类: 易语言 标签: