易语言大漠单线程模块制作系统字库设置行高列高

模块源码:
.版本 2

.子程序 SetDictMem, 整数型, , 从内存中设置字库.注: 此函数速度很慢,全局初始化时调用一次即可,切换字库用UseDict,另外,此函数不支持加密的内存字库.(返回值:0失败,1成功)
.参数 index, 整数型, , index 整形数:字库的序号,取值为0-19,目前最多支持20个字库
.参数 addr, 整数型, , addr 整形数: 数据地址
.参数 size, 整数型, , size 整形数: 字库长度

返回 (obj.数值方法 (“SetDictMem”, index, addr, size))

.子程序 SetDictPwd, 整数型, , 设置字库的密码,在SetDict前调用,目前的设计是,所有字库通用一个密码.(返回值:0失败,1成功)
.参数 pwd, 整数型, , 字库密码

返回 (obj.数值方法 (“SetDictPwd”, pwd))

.子程序 SetExactOcr, 整数型, , 高级用户使用,在使用文字识别功能前,设定是否开启精准识别(返回值:0失败,1成功)精准识别开启后,行间距和列间距会对识别结果造成较大影响,可以在工具中进行测试.
.参数 exact_ocr, 整数型, , exact_ocr 整形数: 0 表示关闭精准识别,1 开启精准识别

返回 (obj.数值方法 (“SetExactOcr”, exact_ocr))

.子程序 SetMinColGap, 整数型, , 高级用户使用,在识别前,如果待识别区域有多行文字,可以设定列间距,默认的列间距是0(返回值:0失败,1成功)。
.参数 min_col_gap, 整数型, , 整形数:最小列间距,注意:此设置如果不为0,那么将不能识别连体字 慎用.

返回 (obj.数值方法 (“SetMinColGap”, min_col_gap))

.子程序 SetMinRowGap, 整数型, , 高级用户使用,在识别前,如果待识别区域有多行文字,以设定行间距,默认的行间距是1,(返回值:0失败,1成功)。
.参数 min_row_gap, 整数型, , 整形数:最小行间距注意:

返回 (obj.数值方法 (“SetMinRowGap”, min_row_gap))

.子程序 SetRowGapNoDict, 整数型, , 高级用户使用,在不使用字库进行词组识别前,可设定文字的行距,默认行距是1(返回值:0失败,1成功)。
.参数 row_gap, 整数型, , 文字行距

返回 (obj.数值方法 (“SetRowGapNoDict”, row_gap))

.子程序 SetWordGap, 整数型, , 高级用户使用,在识别词组前,可设定词组间的间隔,默认的词组间隔是5(返回值:0失败,1成功)。
.参数 word_gap, 整数型, , 单词间距

返回 (obj.数值方法 (“SetWordGap”, word_gap))

.子程序 SetWordGapNoDict, 整数型, , 高级用户使用,在不使用字库进行词组识别前,可设定词组间的间隔,默认的词组间隔是5(返回值:0失败,1成功)。
.参数 word_gap, 整数型, , 单词间距

返回 (obj.数值方法 (“SetWordGapNoDict”, word_gap))

.子程序 SetWordLineHeight, 整数型, , 高级用户使用,在识别词组前,可设定文字的平均行高,默认的词组行高是10(返回值:0失败,1成功)。
.参数 line_height, 整数型, , 整形数:行高

返回 (obj.数值方法 (“SetWordLineHeight”, line_height))

.子程序 SetWordLineHeightNoDict, 整数型, , 高级用户使用,在不使用字库进行词组识别前,可设定文字的平均行高,默认的词组行高是10(返回值:0失败,1成功)。
.参数 line_height, 整数型, , 整形数:行高

返回 (obj.数值方法 (“SetWordLineHeightNoDict”, line_height))

.子程序 SaveDict, 整数型, , 保存指定的字库到指定的文件中.(返回值:0失败,1成功)。
.参数 index, 整数型, , 字库索引序号 取值为0-9对应10个字库
.参数 file, 文本型, , 文件名

返回 (obj.数值方法 (“SaveDict”, index, file))

.子程序 SetColGapNoDict, 整数型, , 高级用户使用,在不使用字库进行词组识别前,可设定文字的列距,默认列距是1(返回值:0失败,1成功)。
.参数 col_gap, 整数型, , 文字列距

返回 (obj.数值方法 (“SetColGapNoDict”, col_gap))

视频教程优酷土豆链接:


发布日期:

所属分类: 易语言 标签: