511遇见易语言软件本地注册验证-13-注册信息写入配置文件

2、软件需要重新启动

3、把注册信息写入本地文件

4、再次启动时,读取已经注册的标识。

注册成功写入源码

.版本 2
.支持库 dp1
.支持库 spec
 
.子程序 _按钮2_被单击
.局部变量 a, 长整数型
.局部变量 b, 长整数型
.局部变量 rdate, 日期时间型
.局部变量 rtext, 文本型
 
a = 注册码_反算 (编辑框2.内容)
b = 系统_取特征码综合 ()
rdate = 取现行时间 ()
rtext = 到文本 (rdate) + “|” + “真”
.判断开始 (a = b)
    信息框 (“注册成功,可以使用所有功能了!”, 0, , )
    写到文件 (取运行目录 () + “\reg.dat”, 加密数据 (到字节集 (rtext), “asdfg”, ))
    延迟 (1000)
    运行 (取执行文件名 (),, )
    结束 ()
.默认
    信息框 (“注册失败!!!”, 0, , )


发布日期:

所属分类: 易语言 标签: