易语言教程流程控制返回和结束和销毁

一、官方源码

返回
调用格式: 〈无返回值〉 返回 ([通用型 返回到调用方的值]) - 系统核心支持库->流程控制
英文名称:return
本命令转移当前程序执行位置到调用本子程序语句的下一条语句处,并可根据需要返回一个值到子程序调用处。本命令为初级命令。
参数<1>的名称为“返回到调用方的值”,类型为“通用型(all)”,可以被省略。

操作系统需求: Windows、Linux、Unix

结束
调用格式: 〈无返回值〉 结束 () - 系统核心支持库->流程控制
英文名称:end
本命令结束当前易程序的运行。本命令为初级命令。

操作系统需求: Windows、Linux、Unix

销毁
调用格式: 〈无返回值〉 对象.销毁 ([逻辑型 立即销毁]) - 系统核心支持库->窗口
英文名称:destroy
销毁本窗口或窗口组件。窗口被销毁后,所有在载入本窗口之后对本窗口及其内窗口组件所进行的修改或设置都将被抛弃,窗口被销毁后如想再次使用必须重新装载。注意:当窗口调用本方法进行销毁时,窗口并不会被立即销毁,而会被推迟到其它所有现存窗口事件处理完毕后才会被真正销毁。本命令为初级对象成员命令。
参数<1>的名称为“立即销毁”,类型为“逻辑型(bool)”,可以被省略。通常情况下,调用销毁方法后为了考虑到事件处理子程序的后续安全操作,窗口真正的销毁工作会被延迟到所处事件处理子程序执行完毕后再进行,但有时由于某种特殊需要,可能希望窗口能够立即被销毁,设置本参数为真即可。注:1.核心库4.6版本以前(不包括4.6)由于不支持本参数,执行本方法始终会立即销毁;2.本参数仅在销毁窗口时有效,销毁窗口组件时始终都采取立即销毁方式。如果被省略,则参数默认值为假。

操作系统需求: Windows

二、视频源码

.版本 2

.程序集 窗口程序集_启动窗口

.子程序 _按钮1_被单击, , , 返回--1
.局部变量 n, 整数型

.计次循环首 (10, n)
.如果真 (n > 5)
返回 ()
.如果真结束
画板1.滚动写行 (n)
.计次循环尾 ()
信息框 (“我被执行到了吗?”, 0, , )

.子程序 _按钮2_被单击, , , 返回--2

.如果真 (子程序1 () = 1)
信息框 (“我被执行到了”, 0, , )
.如果真结束

.子程序 子程序1, 整数型

返回 (1)

.子程序 _按钮3_被单击, , , 返回-3

信息框 (“点击【确定】开始调用自程序”, 0, “调用提示”, )
被调用的子程序 ()
信息框 (“我的位置是返回后的调用位置!!”, 0, “系统提示”, )

.子程序 被调用的子程序

信息框 (“我是被调用的子程序” + #换行符 + #换行符 + “点击【确定】后返回被调用的地方”, 64, “子程序调用提示”, )
返回 ()
信息框 (“我在【返回】之后,所以不会被调用的!!”, 0, “系统提示”, )

.子程序 _按钮4_被单击, , , 返回-4

.如果 (测试返回 () = 真)
信息框 (“我返回了真”, 0, , )

.否则

.如果结束

.子程序 测试返回, 逻辑型, , 返回-4

.如果 (1 + 1 = 3)
返回 (真)

.否则

返回 (假)
信息框 (“我计算错误,返回了【假】了”, 0, , )
.如果结束

.子程序 _按钮5_被单击

载入 (窗口1, , 假)

.子程序 _按钮6_被单击

载入 (窗口2, , 假)

.子程序 _按钮7_被单击

结束 ()

.子程序 _按钮8_被单击

销毁 ()


发布日期:

所属分类: 易语言 标签: