易语言教程逻辑比较

文章目录[隐藏]

教程源码:

.版本 2

.程序集 窗口程序集_启动窗口

.子程序 _编辑框1_按下某键, 逻辑型
.参数 键代码, 整数型
.参数 功能键状态, 整数型

.如果真 (键代码 = 13)
成绩判断系统 ()
.如果真结束

.子程序 成绩判断系统
.局部变量 b, 整数型

' 不及格 0---60
' 及格 60
' 一般 60--75
' 良好 75--90
' 优秀 90--100
' 满分 100
b = 到整数 (编辑框1.内容)
标签1.文本颜色 = #红色
.判断开始 (b < 60 且 b ≥ 0)
标签1.标题 = “不及格!”
.判断 (b = 60)
标签1.标题 = “刚好及格!”
.判断 (b > 60 且 b ≤ 75)
标签1.标题 = “一般,需要加油!”
.判断 (b > 75 且 b ≤ 90)
标签1.标题 = “良好!”
.判断 (b > 90 且 b < 100)
标签1.标题 = “优秀!”
.判断 (b = 100)
标签1.标题 = “满分,太棒了!”
.判断 (b > 100 或 b < 0)
标签1.标题 = “别开玩笑,请重新输入”
编辑框1.内容 = “”
.默认

.判断结束


发布日期:

所属分类: 易语言 标签: