易语言教程读入文件和写到文件

读入文件

调用格式: 〈字节集〉 读入文件 (文本型 文件名) - 系统核心支持库->磁盘操作
英文名称:ReadFile
返回一个字节集,其中包含指定文件的所有数据。本命令为初级命令。
参数<1>的名称为“文件名”,类型为“文本型(text)”。

操作系统需求: Windows、Linux

写到文件

调用格式: 〈逻辑型〉 写到文件 (文本型 文件名,字节集 欲写入文件的数据,... ) - 系统核心支持库->磁盘操作
英文名称:WriteFile
本命令用作将一个或数个字节集顺序写到指定文件中,文件原有内容被覆盖。成功返回真,失败返回假。本命令为初级命令。命令参数表中最后一个参数可以被重复添加。
参数<1>的名称为“文件名”,类型为“文本型(text)”。
参数<2>的名称为“欲写入文件的数据”,类型为“字节集(bin)”。

操作系统需求: Windows、Linux

视频教程源码

.版本 2

.程序集 窗口程序集_启动窗口

.子程序 _按钮1_被单击, , , 读入文件--通用对话框 类型 -0--打开文件

通用对话框1.类型 = 0
.如果真 (通用对话框1.打开 () = 真)
编辑框1.内容 = 到文本 (读入文件 (通用对话框1.文件名)) ' 返回一个字节集,其中包含指定文件的所有数据。本命令为初级命令。

.如果真结束

.子程序 _按钮2_被单击, , , 写到文件--通用对话框 类型 -1--写到文件

通用对话框1.类型 = 1
.如果真 (通用对话框1.打开 () = 真)
写到文件 (通用对话框1.文件名, 到字节集 (编辑框1.内容))

.如果真结束


发布日期:

所属分类: 易语言 标签: