易语言控制程序窗口靠边自动显示隐藏

源码

窗口需要一个时钟组件,我们封装一个自动显示隐藏的子程序。窗口名称采用了默认的_启动窗口。为了体现隐藏的平滑度,时钟周期设为1.

.版本 2

.子程序 靠边隐藏

.如果 (取鼠标水平位置 () ≥ _启动窗口.左边 且 取鼠标水平位置 () < _启动窗口.左边 + _启动窗口.宽度 且 取鼠标垂直位置 () ≥ _启动窗口.顶边 且 取鼠标垂直位置 () < _启动窗口.顶边 + _启动窗口.高度)
.如果真 (_启动窗口.左边 < 0)
_启动窗口.移动 (0, , , )
.如果真结束
.如果真 (_启动窗口.顶边 < 0)
_启动窗口.移动 (, 0, , )
.如果真结束

.如果真 (_启动窗口.左边 > 取屏幕宽度 () - _启动窗口.宽度)
_启动窗口.移动 (取屏幕宽度 () - _启动窗口.宽度, , , )
.如果真结束
.如果真 (_启动窗口.顶边 > 取屏幕高度 () - _启动窗口.高度)
_启动窗口.移动 (, 取屏幕高度 () - _启动窗口.高度, , )
.如果真结束

.否则
.如果真 (_启动窗口.左边 ≤ 0)
_启动窗口.移动 (1 - _启动窗口.宽度, , , )
.如果真结束
.如果真 (_启动窗口.顶边 ≤ 0)
_启动窗口.移动 (, 1 - _启动窗口.高度, , )
.如果真结束

.如果真 (_启动窗口.左边 ≥ 取屏幕宽度 () - _启动窗口.宽度)
_启动窗口.移动 (取屏幕宽度 () - 1, , , )
.如果真结束
.如果真 (_启动窗口.顶边 ≥ 取屏幕高度 () - _启动窗口.高度)
_启动窗口.移动 (, 取屏幕高度 () - 1, , )
.如果真结束


发布日期:

所属分类: 易语言 标签: