大漠多账号循环登录任务自动切换模板-9测试优化

教程源码:

.版本 2

.子程序 是否出现角色, 逻辑型, , 启动成功返回真
.局部变量 x
.局部变量 y

dm.FindPic (0, 0, 2000, 2000, “角色.bmp”, “000000”, 0.9, 0, x, y)
.判断开始 (x > 0 且 y > 0)
返回 (真)
.默认
返回 (假)
.判断结束

.子程序 登录游戏

.判断循环首 (运行状态 > 0)
.判断开始 (是否登录成功 () = 真)
监控反馈 (“进入游戏成功”)
超级延时 (3000, )
跳出循环 ()

.判断 (是否启动成功 () = 真)
.判断循环首 (运行状态 > 0)
.判断开始 (账号 = “”)
切换账号 ()

.默认
跳出循环 ()
.判断结束

.判断循环尾 ()
' 下面就是具体的登录环节
移动点击 (390, 384)
dm.KeyPress (13)
超级延时 (1000, )
dm.KeyPress (13)
超级延时 (1000, )
dm.KeyPress (13)
' 出现选择区的画面
移动点击 (196, 234)
移动点击 (510, 442)
超级延时 (1000, )

' 激活账号输入
超级延时 (1000, )
dm.MoveTo (349, 225)
超级延时 (1000, )
dm.LeftDoubleClick ()
超级延时 (1000, )
.计次循环首 (50, )
dm.KeyPress (8)
.计次循环尾 ()
超级延时 (1000, )
' 开始输入账号
dm.SendString2 (hwnd, 账号)
超级延时 (1000, )
dm.KeyPress (13)
' 输入密码
dm.SendString2 (hwnd, 密码)
超级延时 (1000, )
dm.KeyPress (13)
' 出现选择角色的画面,建议做判断
.判断循环首 (运行状态 > 0)
.判断开始 (是否出现角色 () = 真)
跳出循环 ()
.默认

.判断结束

.判断循环尾 ()
dm.KeyPress (13)
' 登录服务器,出现卡顿,循环等待
.循环判断首 ()

.循环判断尾 (是否登录成功 () = 真)
' 清理游戏画面
超级延时 (4000, )
dm.KeyPress (13)
超级延时 (1000, )
移动点击 (391, 263)

.默认
超级延时 (2000, )
.判断结束

.判断循环尾 ()

.子程序 移动点击
.参数 x
.参数 y

超级延时 (200, )
dm.MoveTo (x, y)
超级延时 (200, )
dm.LeftClick ()
超级延时 (200, )


发布日期:

所属分类: 易语言 标签: