乐玩多线程模块(索引)程序集模块–方法4

乐玩多线程模块源码:

.版本 2

.程序集 集多线程

.子程序 乐玩创建, 逻辑型, 公开
.参数 索引

返回 (lw [索引].创建 ())

.子程序 乐玩释放, , 公开
.参数 索引

lw [索引].乐玩释放 ()

.子程序 ver, 文本型, 公开
.参数 索引

返回 (lw [索引].ver ())

.子程序 BindWindow, 整数型, 公开, 0:失败,1:成功
.参数 hwnd
.参数 display
.参数 mouse
.参数 keypad
.参数 added
.参数 mode
.参数 索引

返回 (lw [索引].BindWindow (hwnd, display, mouse, keypad, added, mode))

.子程序 UnBindWindow, 整数型, 公开, 0:失败,1:成功
.参数 索引

返回 (lw [索引].UnBindWindow ())

.子程序 DownCpu, 整数型, 公开, 0:失败,1:成功
.参数 rate
.参数 索引

返回 (lw [索引].DownCpu (rate))

.子程序 KeyPress, 整数型, 公开, 0:失败,1:成功
.参数 vk_code
.参数 num
.参数 索引

返回 (lw [索引].KeyPress (vk_code, num))

.子程序 EnumWindow, 文本型, 公开
.参数 title, 文本型
.参数 class, 文本型
.参数 processname, 文本型
.参数 pid
.参数 fhwnd
.参数 isvisble
.参数 exacttitle
.参数 索引

返回 (lw [索引].EnumWindow (title, class, processname, pid, fhwnd, isvisble, exacttitle))

乐玩多线程模块调用测试源码:

.版本 2
.支持库 spec
.支持库 EThread
 
.程序集 窗口程序集_启动窗口
.程序集变量 hwnd, 文本型, , "0", 游戏窗口句柄
 
.子程序 __启动窗口_创建完毕
 
' 务必先释放一次,一次即可!!
' 这里的创建的目的是为了下面枚举窗口的调用,索引特意为1
乐玩释放 (1)
乐玩创建 (1)
 
.子程序 _按钮1_被单击
 
多线程绑定 ()
 
.子程序 多线程绑定
.局部变量 m, 整数型
.局部变量 游戏句柄, 文本型
 
' 1、获取游戏窗口句柄
游戏句柄 = EnumWindow (“剑侠情缘·网络版”, “Sword3 Class”, “gamefree.exe”, 0, 0, 0, 0, 1)
调试输出 (游戏句柄)
hwnd = 分割文本 (游戏句柄, “,”, )
.计次循环首 (取数组成员数 (hwnd), m)
    ' 有几个游戏就得创建就几个乐玩对象
    乐玩创建 (m)
    ' 设置全局路径
    ' 设置字库
    ' 屏蔽弹窗错误
    ' 获取句柄
    ' 绑定游戏
    调试输出 (hwnd [m])
    .判断开始 (BindWindow (到整数 (hwnd [m]), 4, 1, 1, 0, 0, m) = 1)
        ' 降低CPU
        DownCpu (60, m)
        ' 启动线程
        启动线程 (&主线程, m, )
    .默认
 
    .判断结束
 
.计次循环尾 ()
 
.子程序 主线程
.参数 d
 
' 这里就是游戏辅助的环节
跑路 (d)
对话 (d)
打怪 (d)
UnBindWindow (d)
 
.子程序 跑路
.参数 数组序号
 
.计次循环首 (10, )
    KeyPress (114, 1, 数组序号)
    延时 (1000)
.计次循环尾 ()
 
.子程序 对话
.参数 数组序号
 
.计次循环首 (10, )
    KeyPress (115, 1, 数组序号)
 
    延时 (1000)
.计次循环尾 ()
 
.子程序 打怪
.参数 数组序号
 
.计次循环首 (10, )
    KeyPress (116, 1, 数组序号)
 
    延时 (1000)
.计次循环尾 ()

教程下载:

链接:https://pan.baidu.com/s/1Z-GwQ84X7iccpK3NngsPZQ

提取码:加QQ群:521068947 群文件下载


发布日期:

所属分类: 易语言 标签: