乐玩插件获取窗口句柄后台模式判断及绑定

乐玩模块源码:

.版本 2

.子程序 FindWindow, 整数型, 公开, 整形数表示的窗口句柄,没找到返回0
.参数 title, 文本型
.参数 class, 文本型
.参数 processname, 文本型
.参数 pid
.参数 fhwnd
.参数 isvisble
.参数 fpid
.参数 exacttitle
.参数 w
.参数 h
.参数 lose
.参数 comd, 文本型
.参数 exactcomd

返回 (obj.数值方法 (“FindWindow”, title, class, processname, pid, fhwnd, isvisble, fpid, exacttitle, w, h, lose, comd, exactcomd))

.子程序 BindWindow, 整数型, 公开, 0:失败,1:成功
.参数 hwnd
.参数 display
.参数 mouse
.参数 keypad
.参数 added
.参数 mode

返回 (obj.数值方法 (“BindWindow”, hwnd, display, mouse, keypad, added, mode))

.子程序 IsBind, 整数型, 公开, 0: 没绑定,或者窗口不存在,1: 已经绑定
.参数 hwnd

返回 (obj.数值方法 (“IsBind”, hwnd))

.子程序 UnBindWindow, 整数型, 公开, 0:失败,1:成功

返回 (obj.数值方法 (“UnBindWindow”, ))

.子程序 ForceUnBindWindow, 整数型, 公开, 0:失败,1:成功
.参数 hwnd

返回 (obj.数值方法 (“ForceUnBindWindow”, hwnd))

.子程序 DownCpu, 整数型, 公开, 0:失败,1:成功
.参数 rate

返回 (obj.数值方法 (“DownCpu”, rate))

调用测试

.版本 2

.子程序 _按钮2_被单击, , , 窗口句柄

hwnd = l.FindWindow (“剑侠情缘·网络版”, “Sword3 Class”, “gamefree.exe”, 0, 0, 0, 0, 0, 0, 0, 0, “”, 0)
信息框 (hwnd, 0, , )

.子程序 _按钮3_被单击
.局部变量 ret

ret = l.BindWindow (hwnd, 4, 1, 1, 0, 0)
' 如何判断后台绑定
' 绑定窗口,必须加1-2秒延时
延时 (2000)
l.DownCpu (50)
' 信息框 (ret, 0, , )

.子程序 _按钮4_被单击
.局部变量 ret

ret = l.IsBind (hwnd)
.判断开始 (ret = 1)
信息框 (“后台绑定成功!”, 0, , )

.默认
信息框 (ret, 0, , )

.判断结束

.子程序 _按钮5_被单击

l.UnBindWindow ()

.子程序 __启动窗口_将被销毁

l.ForceUnBindWindow (hwnd)

教程下载:

链接:https://pan.baidu.com/s/1Z-GwQ84X7iccpK3NngsPZQ

提取码:加QQ群:521068947 群文件下载


发布日期:

所属分类: 易语言 标签: