易语言大漠模块制作键鼠类设置键鼠按下弹起时间

模块源码:

.版本 2
 
.子程序 SetKeypadDelay, 整数型, 公开, 设置按键时,键盘按下和弹起的时间间隔。高级用户使用。某些窗口可能需要调整这个参数才可以正常按键。(返回值:0失败,1成功)
.参数 type, 文本型, , type 字符串: 键盘类型,取值有以下:"normal" : 对应normal键盘  默认内部延时为30ms;"windows": 对应windows 键盘 默认内部延时为10ms;"dx" :     对应dx 键盘 默认内部延时为50ms
.参数 delay, 整数型, , delay 整形数: 延时,单位是毫秒
 
返回 (obj.数值方法 (“SetKeypadDelay”, type, delay))
 
.子程序 SetMouseDelay, 整数型, 公开, 设置鼠标单击或者双击时,鼠标按下和弹起的时间间隔。高级用户使用。某些窗口可能需要调整这个参数才可以正常点击。(返回值:0失败,1成功)
.参数 type, 文本型, , type 字符串:鼠标类型,取值有以下:"normal" : 对应normal鼠标 默认内部延时为 30ms;"w对应windows 鼠标 默认内部延时为 10ms;"dx" : 对应dx鼠标 默认内部延时为40ms
.参数 delay, 整数型, , delay 整形数: 延时,单位是毫秒
 
返回 (obj.数值方法 (“SetMouseDelay”, type, delay))
 
.子程序 SetMouseSpeed, 整数型, 公开, 设置系统鼠标的移动速度.  如图所示红色区域. 一共分为11个级别. 从1开始,11结束。此接口仅仅对开启了硬件模拟鼠标的MoveR接口起作用.(返回值:0失败,1成功)
.参数 speed, 整数型, , speed 整形数:鼠标移动速度, 最小1,最大11.  居中为6. 推荐设置为6
 
返回 (obj.数值方法 (“SetMouseSpeed”, speed))
 
.子程序 SetSimMode, 整数型, 公开, 设置前台键鼠的模拟方式.返回值:(0  : 插件没注册-2 ; 驱动释放失败.-3 ; 驱动加载失败.可能是权限不够. 参考UAC权限设置. 或者是被安全软件拦截. 如果是在64位系统下返回此错误,可能是驱动签名没有关闭导致。点击这里查看如何关闭64位驱动签名.)
.参数 mode, 整数型, , mode 整形数: 0 正常模式(默认模式);1 超级模拟(隐藏驱动) 不支持win8及其以上系统;2 硬件模拟(隐藏驱动);3 超级模拟(但是不隐藏驱动,如果隐藏了驱动有一些异常情况,可以考虑不隐藏) 不支持win8及其以上系统;4 硬件模拟(但是不隐藏驱动,如果隐藏了驱动有一些异常情况,可以考虑不隐藏);5 硬件模拟2(并隐藏驱动)(仅仅支持标准的3键鼠标,即左键,右键,中键,带滚轮的鼠标,2键和5键等扩展鼠标不支持);6 硬件模拟2,同模式5(但是不隐藏驱动,如果隐藏了驱动有一些异常情况,可以考虑不隐藏) (仅仅支持标准的3键鼠标,即左键,右键,中键,带滚轮的鼠标,2键和5键等扩展鼠标不支持)
 
返回 (obj.数值方法 (“SetSimMode”, mode))
 
.子程序 WaitKey, 整数型, 公开, 等待指定的按键按下 (前台,不是后台)返回值:(0:超时;1:指定的按键按下 (当vk_code不为0时);按下的按键码:(当vk_code为0时))
.参数 vk_code, 整数型, , vk_code 整形数:虚拟按键码,当此值为0,表示等待任意按键。 鼠标左键是1,鼠标右键时2,鼠标中键是4.
.参数 time_out, 整数型, , time_out 整形数:等待多久,单位毫秒. 如果是0,表示一直等待
 
返回 (obj.数值方法 (“WaitKey”, vk_code, time_out))
 
.子程序 WheelDown, 整数型, 公开, 滚轮向下滚(返回值:0失败,1成功)
 
返回 (obj.数值方法 (“WheelDown”, ))
 
.子程序 WheelUp, 整数型, 公开, 滚轮向上滚(返回值:0失败,1成功)
 
返回 (obj.数值方法 (“WheelUp”, ))

视频链接


发布日期:

所属分类: 易语言 标签: