易语言数学算法水仙花数

源码:

窗口放置一个编辑框来显示结果,编辑框设置为多行显示。鉴于运算速度,我们这里演示了100-999.

.版本 2
 
.子程序 _计算图形按钮_被单击
.局部变量 循环变量, 整数型, , , 循环中的计数变量
.局部变量 百位数, 整数型, , , 存放百位上的数字
.局部变量 十位数, 整数型, , , 存放十位上的数字
.局部变量 个位数, 整数型, , , 存放个位上的数字
 
' 先将结果编辑框中的内容清空
结果编辑框.内容 = “”
' 第一个三位数
循环变量 = 100
' 从100到999中的三位数中寻找水仙花数
.判断循环首 (循环变量 < 1000)
    ' 取出这个三位数中百位上的数
    百位数 = 循环变量 \ 100
    ' 取出这个三位数中十位上的数
    十位数 = (循环变量 % 100) \ 10
    ' 取出这个三位数中个位上的数
    个位数 = 循环变量 % 10
    ' 判断这个数是否等于各个位上的数的立方和
    .如果真 (循环变量 = 百位数 × 百位数 × 百位数 + 十位数 × 十位数 × 十位数 + 个位数 × 个位数 × 个位数)
        结果编辑框.加入文本 (到文本 (循环变量), “,”)
    .如果真结束
    ' 下一个三位数
    循环变量 = 循环变量 + 1
.判断循环尾 ()

发布日期:

所属分类: 易语言 标签: