易语言ScreenToClient屏幕坐标到客户去坐标

到客户区坐标ScreenToClient

.版本 2
 
.DLL命令 到客户区坐标_, 整数型, "user32.dll", "ScreenToClient", , ScreenToClient,Long,非零表示成功,零表示失败
    .参数 窗口句柄, 整数型, , hwnd,Long,一个窗口的句柄,该窗口定义了要使用的客户区坐标系统
    .参数 点, 坐标_, , POINTAPI,屏幕坐标系统中包含了屏幕点的结构。这个函数会随同相应的客户区坐标(由hwnd决定)载入结构

数据类型POINTAPI

.版本 2
 
.数据类型 坐标_, , POINTAPI
    .成员 横向位置, 整数型, , , x
    .成员 纵向位置, 整数型, , , y

易语言调用

.版本 2
 
.程序集 窗口程序集_启动窗口
 
.子程序 _按钮_到客户区坐标_被单击
.局部变量 局部_坐标, 坐标_
 
.如果真 (到客户区坐标_ (_启动窗口.取窗口句柄 (), 局部_坐标)1)
    标签_运行结果.标题 = “横坐标有” + 到文本 (局部_坐标.横向位置) + “点” + #换行符 + “纵坐标有” + 到文本 (局部_坐标.纵向位置) + “点”
.如果真结束

发布日期:

所属分类: 易语言 标签: