易语言教程用多文件对话框写MP3播放器

.版本 2
.支持库 iext
.支持库 xplib

.程序集 窗口程序集_启动窗口

.子程序 _按钮2_被单击, , , 打开
.局部变量 文本数组, 文本型, , "0"
.局部变量 i, 整数型
.局部变量 索引, 整数型

文本数组 = 多文件对话框 (“请选择你要播放的本地歌曲”, “歌曲(*.mp3) |*.mp3”, , , , )
.计次循环首 (取数组成员数 (文本数组), i)
索引 = 超级列表框1.插入表项 (, 文本数组 [i], , , , )
超级列表框1.置标题 (索引, 2, 数值到格式文本 (取文件尺寸 (文本数组 [i]) ÷ 1024 ÷ 1024, 3, 假) + “mb”) ' 文件大小
超级列表框1.置标题 (索引, 1, 取文本右边 (文本数组 [i], 取文本长度 (文本数组 [i]) - 倒找文本 (文本数组 [i], “\”, , 假))) ' 文件名
.计次循环尾 ()

.子程序 __启动窗口_创建完毕

XP风格 (2)

.子程序 _超级列表框1_左键单击表项

播放MP3 (-1, 超级列表框1.取标题 (超级列表框1.现行选中项, ))

.子程序 _按钮1_被单击

暂停播放MP3 ()


发布日期:

所属分类: 易语言 标签: