易语言汇编主程序和DLL交换数据数组类型

文本数组DLL源码:

.版本 2
 
.子程序 dll4, , 公开, 4-文本型数组
.参数 保存地址, 整数型
.局部变量 A, 文本型, , "0"
.局部变量 n, 整数型
 
.计次循环首 (10, n)
    重定义数组 (A,, n)
    A [n] = “我来自DLL文本型数组---” + 到文本 (n)
.计次循环尾 ()
交换变量数据_地址交地址ASM (取变量地址_ASM数组 (A), 保存地址)

字节集数组DLL源码:

.版本 2
 
.子程序 dll5, , 公开, 5-字节集数组
.参数 保存地址, 整数型
.局部变量 A, 字节集, , "0"
.局部变量 n, 整数型
 
.计次循环首 (10, n)
    重定义数组 (A,, n)
    A [n] = 到字节集 (“我来自DLL字节集型数组---” + 到文本 (n))
.计次循环尾 ()
交换变量数据_地址交地址ASM (取变量地址_ASM数组 (A), 保存地址)

动态调用DLL文本数组源码:

.版本 2
 
.子程序 _按钮4_被单击, , , 4-文本型数组
.局部变量 A, 文本型, , "0"
.局部变量 地址, 整数型
.局部变量 命令地址, 整数型
.局部变量 参数数据地址, 整数型, , "1"
.局部变量 i, 整数型
.局部变量 txt, 文本型
 
' 1-获取变量地址
地址 = 取变量地址_ASM数组 (A)
' 2-获取函数命令地址
命令地址 = 取DLL命令地址_ASM (dll路径, “dll4”)
' 调用这个函数方法,第二个参数 参数数据地址 是数组,必须转换一下
参数数据地址 [1] = 地址
' 4-调用这个命令方法
调用命令_ASM (命令地址, 参数数据地址, )
.计次循环首 (取数组成员数 (A), i)
    txt = txt + A [i] + #换行符
.计次循环尾 ()
编辑框1.内容 = txt

动态调用DLL字节集数组源码:

.版本 2
 
.子程序 _按钮5_被单击, , , 5-字节集数组
.局部变量 A, 字节集, , "0"
.局部变量 地址, 整数型
.局部变量 命令地址, 整数型
.局部变量 参数数据地址, 整数型, , "1"
.局部变量 i, 整数型
.局部变量 txt, 文本型
 
' 1-获取变量地址
地址 = 取变量地址_ASM数组 (A)
' 2-获取函数命令地址
命令地址 = 取DLL命令地址_ASM (dll路径, “dll5”)
' 调用这个函数方法,第二个参数 参数数据地址 是数组,必须转换一下
参数数据地址 [1] = 地址
' 4-调用这个命令方法
调用命令_ASM (命令地址, 参数数据地址, )
.计次循环首 (取数组成员数 (A), i)
    txt = txt + 到文本 (A [i]) + #换行符
.计次循环尾 ()
编辑框1.内容 = txt

静态调用DLL文本数组源码:

.版本 2
 
.子程序 _按钮4_被单击, , , 4-文本型数组
.局部变量 地址, 整数型
.局部变量 A, 文本型, , "0"
.局部变量 i, 整数型
.局部变量 txt, 文本型
 
地址 = 取变量地址_ASM数组 (A)
dll4 (地址)
.' 计次循环首 (取数组成员数 (A), i)
    ' 调试输出 (A [i])
.' 计次循环尾 ()
 
.计次循环首 (取数组成员数 (A), i)
    txt = txt + A [i] + #换行符
.计次循环尾 ()
 
编辑框1.内容 = txt

静态调用DLL字节集数组源码:

.版本 2
 
.子程序 _按钮4_被单击, , , 4-文本型数组
.局部变量 地址, 整数型
.局部变量 A, 文本型, , "0"
.局部变量 i, 整数型
.局部变量 txt, 文本型
 
地址 = 取变量地址_ASM数组 (A)
dll4 (地址)
.' 计次循环首 (取数组成员数 (A), i)
    ' 调试输出 (A [i])
.' 计次循环尾 ()
 
.计次循环首 (取数组成员数 (A), i)
    txt = txt + A [i] + #换行符
.计次循环尾 ()
 
编辑框1.内容 = txt

教程下载:


发布日期:

所属分类: 易语言 标签: