易语言大漠模块制作教程图片预加载和设置密码

视频教程源码:

.版本 2

.子程序 AppendPicAddr, 文本型, 公开, 对指定的数据地址和长度,组合成新的参数. FindPicMem FindPicMemE 以及FindPicMemEx专用;返回值:(新的地址描述串)
.参数 pic_info, 文本型, , pic_info 字符串: 老的地址描述串
.参数 addr, 整数型, , addr 整形数: 数据地址
.参数 size, 整数型, , size 整形数: 数据长度

返回 (obj.文本方法 (“AppendPicAddr”, pic_info, addr, size))

.子程序 BGR2RGB, 文本型, 公开, 把BGR(按键格式)的颜色格式转换为RGB返回值:(RGB格式的字符串)
.参数 bgr_color, 文本型, , bgr_color 字符串:bgr格式的颜色字符串

返回 (obj.文本方法 (“BGR2RGB”, bgr_color))

.子程序 ImageToBmp, 整数型, 公开, 转换图片格式为24位BMP格式.(RGB格式的字符串)返回值:(0:失败;1:成功)
.参数 pic_name, 文本型, , pic_name 字符串: 要转换的图片名
.参数 bmp_name, 文本型, , bmp_name 字符串: 要保存的BMP图片名

返回 (obj.文本方法 (“ImageToBmp”, pic_name, bmp_name))

.子程序 IsDisplayDead, 整数型, 公开, 判断指定的区域,在指定的时间内(秒),图像数据是否一直不变.(卡屏).返回值:(0 : 没有卡屏,图像数据在变化.1 : 卡屏. 图像数据在指定的时间内一直没有变化.)
.参数 x1, 整数型, , x1 整形数:区域的左上X坐标
.参数 y1, 整数型, , y1 整形数:区域的左上Y坐标
.参数 x2, 整数型, , x2 整形数:区域的右下X坐标
.参数 y2, 整数型, , y2 整形数:区域的右下Y坐标
.参数 t, 整数型, , t 整形数:需要等待的时间,单位是秒

返回 (obj.数值方法 (“IsDisplayDead”, x1, y1, x2, y2, t))

.子程序 LoadPic, 整数型, 公开, 预先加载指定的图片,这样在操作任何和图片相关的函数时,将省去了加载图片的时间。调用此函数后,没必要一定要调用FreePic,插件自己会自动释放.返回值:(0失败,1成功)
.参数 pic_name, 文本型, , pic_name 字符串: 文件名比如"1.bmp|2.bmp|3.bmp" 等,可以使用通配符,比如"*.bmp" 这个对应了所有的bmp文件;"a?c*.bmp" 这个代表了所有第一个字母是a 第三个字母是c 第二个字母任意的所有bmp文件;"abc???.bmp|1.bmp|aa??.bmp" 可以这样任意组合.

返回 (obj.数值方法 (“LoadPic”, pic_name))

.子程序 LoadPicByte, 整数型, 公开, 返回值:(0失败,1成功)预先加载指定的图片,这样在操作任何和图片相关的函数时,将省去了加载图片的时间。
.参数 addr, 整数型, , addr 整形数: BMP图像首地址.(完整的BMP图像,不是经过解析的. 和BMP文件里的内容一致)
.参数 size, 整数型, , size 整形数: BMP图像大小.(和BMP文件大小一致)
.参数 pic_name, 文本型, , pic_name 字符串: 文件名,指定这个地址对应的图片名. 用于找图时使用.

返回 (obj.数值方法 (“LoadPicByte”, addr, size, pic_name))

.子程序 MatchPicName, 文本型, 公开, 根据通配符获取文件集合. 方便用于FindPic和FindPicEx;返回值:(返回的是通配符对应的文件集合,每个图片以|分割)
.参数 pic_name, 文本型, , pic_name 字符串: 文件名比如"1.bmp|2.bmp|3.bmp" 等,可以使用通配符,比如"*.bmp" 这个对应了所有的bmp文件;"a?c*.bmp" 这个代表了所有第一个字母是a 第三个字母是c 第二个字母任意的所有bmp文件;"abc???.bmp|1.bmp|aa??.bmp" 可以这样任意组合.

返回 (obj.文本方法 (“MatchPicName”, pic_name))

.子程序 RGB2BGR, 文本型, 公开, 把RGB的颜色格式转换为BGR(按键格式);返回值:(BGR格式的字符串)
.参数 rgb_color, 文本型, , rgb_color 字符串:rgb格式的颜色字符串

返回 (obj.文本方法 (“RGB2BGR”, rgb_color))

.子程序 SetPicPwd, 整数型, 公开, 设置图片密码,如果图片本身没有加密,那么此设置不影响不加密的图片,一样正常使用.返回值:(0:失败;1:成功)
.参数 pwd, 文本型, , pwd 字符串: 图片密码

返回 (obj.数值方法 (“SetPicPwd”, pwd))

视频教程优酷土豆链接


发布日期:

所属分类: 易语言 标签: