易语言模块API视频教程窗口取句柄模糊

API FindWindowExA

.版本 2

.DLL命令 FindWindowExA, 整数型, "user32", "FindWindowExA", 公开, 窗口_取句柄ExA 在窗口列表中寻找与指定条件相符的第一个子窗口 找到的窗口的句柄。如未找到相符窗口,则返回零。会设置GetLastError
.参数 父窗口句柄, 整数型, , 在其中查找子的父窗口。如设为零,表示使用桌面窗口(通常说的顶级窗口都被认为是桌面的子窗口,所以也会对它们进行查找)
.参数 子窗口, 整数型, , 从这个窗口后开始查找。这样便可利用对FindWindowEx的多次调用找到符合条件的所有子窗口。如设为零,表示从第一个子窗口开始搜索
.参数 类名, 文本型, , 欲搜索的类名。零表示忽略
.参数 标题, 文本型, , 欲搜索的类名。零表示忽略;

窗口_取句柄_模糊 源码

.版本 2

.子程序 窗口_取句柄_模糊, 整数型, 公开, 成功返回指定窗口的句柄,失败返回 0
.参数 窗口标题, 文本型, 可空, 支持标题模糊,填写的模糊的标题的一部分内容,尽量选用的词在激活的窗口中是唯一的。
.参数 窗口类名, 文本型, 可空, 窗口类名,必须准确精确,或为空不填
.局部变量 局_窗口句柄, 整数型
.局部变量 TitleName, 文本型, , , 局部窗口标题

.判断循环首 (真)
局_窗口句柄 = FindWindowExA (0, 局_窗口句柄, 窗口类名, 字符 (0))
.如果 (局_窗口句柄 > 0)
TitleName = 到小写 (窗口_取标题 (局_窗口句柄))
.如果真 (寻找文本 (TitleName, 到小写 (窗口标题), , 假) ≠ -1)
返回 (局_窗口句柄)
.如果真结束

.否则
跳出循环 ()
.如果结束

.判断循环尾 ()
返回 (0)


发布日期:

所属分类: 易语言 标签: