易语言模块API视频教程线程初始化com库(CoInitialize)

API--CoInitialize

CoInitialize是Windows提供的API函数,用来告诉 Windows以单线程的方式创建com对象。应用程序调用com库函数(除CoGetMalloc和内存分配函数)之前必须初始化com库。
使用 CoInitialize 创建可以使对象直接与线程连接,得到最高的性能。
CoInitialize并不装载COM 库,它只用来初始化当前线程使用什么样的套件。使用这个函数后,线程就和一个套件建立了对应关系。线程的套件模式决定了该线程如何调用COM对象,是否需要列集等。
CoInitialize ()并不会干扰客户和服务器之间的通信,它所做的事情是让线程注册一个套件,而线程运行过程中必然在此套件。

.版本 2

.DLL命令 CoInitialize, , "ole32.dll", "CoInitialize", , 线程_初始化com
.参数 pvReserved, 整数型, , 为 0

模块源码

.版本 2

.子程序 线程_初始化com, , 公开, 在调用com库之前必须初始化一下,在线程使用COM前!!!

CoInitialize (0)


发布日期:

所属分类: 易语言 标签: