易语言模块API视频教程窗口取句柄(FindWindowA)

API FindWindowA 源码

.版本 2

.DLL命令 FindWindowA, 整数型, "user32", "FindWindowA", 公开, 寻找窗口列表中第一个符合指定条件的顶级窗口(在vb里使用:FindWindow最常见的一个用途是获得ThunderRTMain类的隐藏窗口的句柄;该类是所有运行中vb执行程序的一部分。获得句柄后,可用api函数GetWindowText取得这个窗口的名称;该名也是应用程序的标题) 找到窗口的句柄。如未找到相符窗口,则返回零。会设置GetLastError
.参数 窗口类名, 文本型, , 指向包含了窗口类名的空中止(C语言)字串的指针;或设为零,表示接收任何类
.参数 窗口标题, 文本型, , 指向包含了窗口文本(或标签)的空中止(C语言)字串的指针;或设为零,表示接收任何窗口标题 示例Dim hw&, cnt&Dim rttitle As * 256hw& = FindWindow("ThunderRT5Main", vbNullString) ' ThunderRTMain under VB4cnt = GetWindowText(hw&, rttitle, 255)MsgBox Left$(rttitle, cnt), 0, "RTMain title";

窗口取句柄封装源码

.版本 2

.子程序 窗口_取句柄, 整数型, 公开, 找到窗口的句柄。如未找到相符窗口,则返回零。
.参数 窗口类名, 文本型, 可空, 窗口的类名
.参数 窗口标题, 文本型, 可空, 窗口的标题

返回 (FindWindowA (窗口类名, 窗口标题))


发布日期:

所属分类: 易语言 标签: