易语言模块API视频教程线程创建(CreateThread)

关闭CloseHandle

.版本 2

.DLL命令 CloseHandle, 整数型, "kernel32", "CloseHandle", , 关闭一个内核对象。其中包括文件、文件映射、进程、线程、安全和同步对象等。涉及文件处理时,这个函数通常与vb的close命令相似。应尽可能的使用close,因为它支持vb的差错控制。注意这个函数使用的文件句柄与vb的文件编号是完全不同的 非零表示成功,零表示失败。会设置GetLastError
.参数 对象句柄, 整数型, , 欲关闭的一个对象的句柄;
------------------------------

封装源码:

.版本 2

.子程序 线程_创建, 整数型, 公开, 返回0表示失败,(同线程_启动)
.参数 要启动的子程序, 子程序指针, , 要启动的子程序
.参数 要传去子程序的参数, 整数型, 可空, 给子程序传递一个整数型的参数
.参数 线程句柄, 整数型, 参考 可空
.参数 立即激活, 逻辑型, 可空, 默认为空为真
.局部变量 线程状态, 整数型
.局部变量 局_线程句柄, 整数型
.局部变量 线程ID, 整数型

线程状态 = 4
.如果真 (立即激活 = 真 或 是否为空 (立即激活) = 真)
线程状态 = 0
.如果真结束
局_线程句柄 = CreateThread (0, 0, 要启动的子程序, 要传去子程序的参数, 线程状态, 线程ID)
.如果真 (局_线程句柄 < 1)
返回 (0)
.如果真结束
.如果 (是否为空 (线程句柄))
CloseHandle (局_线程句柄)
.否则
线程句柄 = 局_线程句柄
.如果结束
返回 (线程ID)


发布日期:

所属分类: 后端 标签: