易语言QueryPerformanceCounter获取高精度微秒计时器总的计数值

查询执行计数器 QueryPerformanceCounter

.版本 2
 
.DLL命令 查询执行计数器_, 整数型, "kernel32", "QueryPerformanceCounter", , 可以得到定时器的当前值
    .参数 计数器, 长整数型_, , 此参数的意思请看msdn帮助

自定义数据类型LARGE_INTEGER

LARGE_INTEGER,此数据类型的意思请看msdn帮助

.版本 2
 
.数据类型 长整数型_, , LARGE_INTEGER,此数据类型的意思请看msdn帮助
    .成员 低三十二位, 整数型, , , lowpart
    .成员 高三十二位, 整数型, , , highpart

易语言执行调用源码

.版本 2
 
.程序集 窗口程序集_启动窗口
 
.子程序 _按钮_查询_被单击
.局部变量 局部_字节集数据, 长整数型_
.局部变量 局部_数据, 长整数型
 
查询执行计数器_ (局部_字节集数据)
局部_数据 = 取字节集数据 (到字节集 (局部_字节集数据.低三十二位) + 到字节集 (局部_字节集数据.高三十二位), #长整数型, )
编辑框_运行结果.加入文本 (“时间记号计数:” + 到文本 (局部_数据), #换行符)

返回:
时间记号计数:124250469894


发布日期:

所属分类: 易语言 标签: