易语言获取混音设备名称

打开混合设备mixerOpen

.版本 2
 
.DLL命令 打开混合设备_, 整数型, "winmm.dll", "mixerOpen", , 打开混合设备
    .参数 混音设备句柄, 整数型, 传址, 返回混音设备句柄 
    .参数 uMxId, 整数型
    .参数 dwCallback, 整数型
    .参数 dwInstance, 整数型
    .参数 fdwOpen, 整数型

获取混合器ID值mixerGetID

.版本 2
 
.DLL命令 取混音设备标识符值_, 整数型, "winmm.dll", "mixerGetID", , 获取混合器ID值
    .参数 混音设备句柄, 整数型, , hmxobj
    .参数 标识符值, 整数型, 传址, puMxId 
    .参数 标志, 整数型, , fdwId

取混音设备性能mixerGetDevCapsA

.版本 2
 
.DLL命令 取混音设备性能_, 整数型, "winmm.dll", "mixerGetDevCapsA", , 获取混合器性能
    .参数 标识符值, 整数型, , uMxId
    .参数 设备性能结构, 混音设备性能_, 传址, pmxcaps
    .参数 结构大小, 整数型, , cbmxcaps

数据类型MIXERCAPS

.版本 2
 
.数据类型 混音设备性能_, , MIXERCAPS
    .成员 厂商识别符, 短整数型, , , wMid
    .成员 产品识别符, 短整数型, , , wPid
    .成员 驱动版本, 整数型, , , vDriverVersion
    .成员 产品名称, 字节型, , "32", szPname
    .成员 支持功能, 整数型, , , fdwSupport
    .成员 目的文件, 整数型, , , cDestinations

取混音设备名称源码

.版本 2

.程序集 窗口程序集_启动窗口
.程序集变量 程序集_句柄, 整数型

.子程序 __启动窗口_创建完毕

打开混合设备_ (程序集_句柄, 0, 0, 0, 0)

.子程序 _按钮_取混音设备名称_被单击
.局部变量 局部_ID值, 整数型
.局部变量 局部_返回数据, 混音设备性能_
.局部变量 局部_名称, 字节集
.局部变量 局部_计次, 整数型

取混音设备标识符值_ (程序集_句柄, 局部_ID值, 0)
取混音设备性能_ (局部_ID值, 局部_返回数据, 48)
局部_名称 = 取空白字节集 (取数组成员数 (局部_返回数据.产品名称))
.计次循环首 (取数组成员数 (局部_返回数据.产品名称), 局部_计次)
局部_名称 [局部_计次] = 局部_返回数据.产品名称 [局部_计次]
.计次循环尾 ()
编辑框_名称.内容 = 取字节集数据 (局部_名称, #文本型, )


发布日期:

所属分类: 易语言 标签: