第七课 易语言调用C++编写的Dll

c++编写的32位 dll源码:

// dllmain.cpp : 定义 DLL 应用程序的入口点。
#include "stdafx.h"
 
BOOL APIENTRY DllMain( HMODULE hModule,
                       DWORD  ul_reason_for_call,
                       LPVOID lpReserved
					 )
{
	switch (ul_reason_for_call)
	{
	case DLL_PROCESS_ATTACH:
	case DLL_THREAD_ATTACH:
	case DLL_THREAD_DETACH:
	case DLL_PROCESS_DETACH:
		break;
	}
	return TRUE;
}
 
extern "C" __declspec(dllexport) int _stdcall  add(int a, int b)
{
	return (a + b);
}
 
extern "C" __declspec(dllexport) int _stdcall  sub(int a, int b)
{
	return (a - b);
}

易语言调用c++

.版本 2
 
.DLL命令 add, 整数型, "edll.dll", "_add@8"
    .参数 a, 整数型
    .参数 b, 整数型
 
.DLL命令 sub, 整数型, "edll.dll", "_sub@8"
    .参数 a, 整数型
    .参数 b, 整数型
.版本 2
 
.程序集 窗口程序集_启动窗口
 
.子程序 _按钮1_被单击
 
编辑框3.内容 = 到文本 (add (到整数 (编辑框1.内容), 到整数 (编辑框2.内容)))
 
.子程序 _按钮2_被单击
 
编辑框6.内容 = 到文本 (sub (到整数 (编辑框4.内容), 到整数 (编辑框5.内容)))


发布日期:

所属分类: 易语言 标签: