易语言全局键盘鼠标钩子QQ聊天窗口自定义小尾巴

文本_投递源码:

.版本 2
 
.子程序 文本_投递
.参数 hwnd, 整数型, , 窗口句柄
.参数 text, 文本型, , 发送的文本
.局部变量 message, 字节集
.局部变量 i, 整数型
 
message = 到字节集 (text)
.计次循环首 (取字节集长度 (message), i)
    PostMessageA (hwnd, 258, message [i], 0)
.计次循环尾 ()

安装键盘钩子

键盘钩子 = SetWindowsHookExA (13, &键盘钩子, GetModuleHandleA (0), 0)

键盘钩子回调函数,功能在这里实现:

.版本 2
.支持库 eAPI
.子程序 键盘钩子, 整数型
.参数 ncode, 整数型, , 钩子子程用来确定如何处理消息的代码
.参数 wParam, 整数型, , 虚拟键码
.参数 lParam, 整数型, , 指向KBDLLHOOKSTRUCT结构的指针
.局部变量 按键信息, KBDLLHOOKSTRUCT
 
CopyMemory (按键信息, lParam, 28)
' 256按键按下
.判断开始 (wParam = 256)
    .判断开始 (按键信息.vkCode = #回车键)
        文本_投递 (取鼠标所在窗口句柄 (), 编辑框1.内容)
    .默认
    .判断结束
    .判断开始 (按键信息.vkCode = #Home键)
        返回 (1)
    .默认
    .判断结束
.判断 (wParam = 257)
    .判断开始 (按键信息.vkCode = #Home键)
        .判断开始 (可视 = 真)
            可视 = 假
        .默认
            可视 = 真
        .判断结束
        返回 (1)
    .默认
    .判断结束
.默认
.判断结束
返回 (CallNextHookEx (键盘钩子, ncode, wParam, lParam))

卸载键盘钩子

UnhookWindowsHookEx (键盘钩子)

自定义QQ尾巴内容,其中/hb /se是QQ表情符号:

  1. -------消息来自511遇见官网客户端 /hb /se

511遇见全部视频教程百度网盘下载

511遇见易语言DLL制作调用及hook注入

资源教程交流①群:521068947

511遇见QQ: 272586593


发布日期:

所属分类: 易语言 标签: