42-大漠多线程模板-12游戏实例化

教程源码:

.版本 2
.支持库 EThread

.程序集 脚本

.子程序 脚本主线程, , , 游戏的动作逻辑都在这里
.参数 序号, 整数型
.局部变量 dm, dmsoft
.局部变量 dm_ret, 整数型
.局部变量 死循环, 逻辑型
.局部变量 任务完成, 文本型

' 要把大漠插件接口初始化为MAT线程模型
CoInitializeEx (0, 0)
线程信息 [序号].线程状态 = #线程状态_正在运行

多线程_异步通知UI (#通知类型_更新, 序号)
' 创建对象
线程信息 [序号].dm.创建 ()
dm = 线程信息 [序号].dm

.如果真 (dm.Ver () = “”)
日志输出 (“大漠对象创建失败”)
多线程_异步通知UI (#通知类型_停止, 序号)
返回 ()
.如果真结束

' 开启全局字库
' dm.EnableShareDict ()
' 设置全局路径
dm.SetPath (“c:\test”)
'