511遇见易语言多线程大漠多线程-3线程传参数据变量地址

L-3传参-变量数据地址

• 1、变量数据地址=取变量数据地址()
• 2、启动线程(,变量数据地址,,)
• 3、指针到文本(变量数据地址)

课程源码:

.版本 2
.支持库 spec
.支持库 EThread
 
.程序集 窗口程序集_启动窗口
 
.子程序 _按钮1_被单击
.局部变量 文本, 文本型
.局部变量 地址, 整数型
 
文本 = “511遇见(www.511yj.com)”
地址 = 取变量数据地址 (文本)
 
启动线程 (&子程序1, 地址, )
 
.子程序 子程序1
.参数 参地址, 整数型
.局部变量 接受文本, 文本型
 
接受文本 = 指针到文本 (参地址)
调试输出 (接受文本)
.版本 2
.支持库 spec
.支持库 EThread
 
.程序集 窗口程序集_启动窗口
 
.子程序 _按钮1_被单击
.局部变量 文本, 文本型
.局部变量 地址, 整数型
 
文本 = “511遇见|www.511yj.com|不一样的遇见”
地址 = 取变量数据地址 (文本)
启动线程 (&子程序1, 地址, )
 
 
.子程序 子程序1
.参数 参_地址, 整数型
.局部变量 接受文本, 文本型
.局部变量 str, 文本型, , "0"
.局部变量 n, 整数型
 
接受文本 = 指针到文本 (参_地址)
str = 分割文本 (接受文本, “|”, )
.计次循环首 (取数组成员数 (str), n)
    调试输出 (str [n])
.计次循环尾 ()


发布日期:

所属分类: 易语言 标签: