511遇见易语言多线程大漠多线程-4线程传参指针地址

L4-传参-指针地址

• 1、到字节集(文本变量)
• 2、取字节集长度()
• 3、取指针地址()
• 4、线程启动(&子程序1,指针地址,)
课程源码:

.程序集 窗口程序集_启动窗口
.程序集变量 字节集长度, 整数型
.程序集变量 字节集变量, 字节集
 
.子程序 _按钮1_被单击
.局部变量 传参地址
 
字节集变量 = 到字节集 (编辑框1.内容)
字节集长度 = 取字节集长度 (字节集变量)
传参地址 = 取指针地址 (字节集变量)
启动线程 (&子程序1, 传参地址, )
 
 
.子程序 子程序1
.参数 参_地址, 整数型
.局部变量 接受的字节集, 字节集
.局部变量 接受转换文本, 文本型
 
接受的字节集 = 指针到字节集 (参_地址, 字节集长度)
接受转换文本 = 取字节集数据 (接受的字节集, #文本型, )
信息框 (接受转换文本, 0, , )
.版本 2
.支持库 shellEx
.支持库 EThread
 
.子程序 _按钮1_被单击
.局部变量 传参地址
 
字节集变量 = 到字节集 (编辑框1.内容 + “|” + 编辑框2.内容)
字节集长度 = 取字节集长度 (字节集变量)
传参地址 = 取指针地址 (字节集变量)
启动线程 (&子程序1, 传参地址, )
 
 
.子程序 子程序1
.参数 参_地址, 整数型
.局部变量 接受的字节集, 字节集
.局部变量 接受转换文本, 文本型
.局部变量 str, 文本型, , "2"
 
接受的字节集 = 指针到字节集 (参_地址, 字节集长度)
接受转换文本 = 取字节集数据 (接受的字节集, #文本型, )
str = 分割文本 (接受转换文本, “|”, )
 
信息框 (“账号:” + str [1] + #换行符 + “” + “密码:” + str [2], 0, , )


发布日期:

所属分类: 易语言 标签: