511遇见易语言软件本地注册验证-12-注册码生成与验证

1、加入注册检测,判断软件是否注册;

2、生成注册码,保证一个用户名只生成与之唯一对应的注册码;

3、注册和试用,限制软件功能的局限性;

课程提纲:

 
1、注册码和客户端绑定
 
2、注册码生成
 
3、注册码验证
 
4、一元算法注册码(用户名或者机器码)
 
5、二元算法注册码(用户名+者机器码)
 
6、注册码(机器码+软件试用时间)

注册码反算源码:

.版本 2
 
.子程序 注册码_反算, 长整数型, 公开, 在客户端验证使用
.参数 注册码, 文本型
.局部变量 t, 长整数型
.局部变量 a, 整数型
 
a = 到整数 (系统_取特征码综合 ())
t = 到长整数 (进制转换 (注册码, 16, 10))
t = t + a × 1
t = t - a × 2
t = t - a × 3
t = t - a × 4
t = t - a × 5
t = t - a × 6
t = t - a × 7
返回 (t)

注册码算法源码:

.版本 2
 
.子程序 注册码_生成, 文本型
.参数 t, 长整数型
.局部变量 a, 整数型
 
a = 到整数 (t)
t = t + a × 7
t = t + a × 6
t = t + a × 5
t = t + a × 4
t = t + a × 3
t = t + a × 2
t = t - a × 1
返回 (到十六 (t))


发布日期:

所属分类: 易语言 标签: