第11课易语言大漠游戏外挂一键登录判断角色位置

1、判断单选框

.版本 2
 
.子程序 判断单选框
 
.判断开始 (单选框_左.选中 = 真)
    位置变量 = “左”
 
.判断 (单选框_中.选中 = 真)
    位置变量 = “中”
 
.判断 (单选框_右.选中 = 真)
    位置变量 = “右”
 
.判断 (单选框_左2.选中 = 真)
    位置变量 = “左2”
 
.判断 (单选框_单.选中 = 真)
    位置变量 = “单”
 
.判断 (单选框_右2.选中 = 真)
    位置变量 = “右2”
.默认
 
.判断结束

2、视频教程

3、选择角色

.版本 2
.支持库 spec
 
.子程序 选择角色
.参数 角色位置, 文本型
.局部变量 i, 整数型
.局部变量 word, 文本型
.局部变量 w_array, 文本型, , "0"
 
延迟 (time)
i = 0
.判断循环首 (i = 0)
    word = dm.FindStrFastE (352, 570, 459, 602, “此账号”, “ffffff-000000”, 1)
    w_array = 分割文本 (word, “|”, )
    .如果 (到整数 (w_array [1])0)
        i = 1
 
    .否则
 
    .如果结束
 
    处理事件 ()
 
.判断循环尾 ()
 
.如果真 (位置变量 = “左”)
    延迟 (time)
    dm.MoveTo (152, 306)
    延迟 (time)
    dm.LeftDoubleClick ()
    延迟 (time)
 
.如果真结束
 
.如果真 (位置变量 = “中”)
    延迟 (time)
    dm.MoveTo (404, 322)
    延迟 (time)
    dm.LeftDoubleClick ()
    延迟 (time)
.如果真结束
 
.如果真 (位置变量 = “右”)
    延迟 (time)
    dm.MoveTo (660, 337)
    延迟 (time)
    dm.LeftDoubleClick ()
    延迟 (time)
 
.如果真结束
 
.如果真 (位置变量 = “左2)
    延迟 (time)
    dm.MoveTo (236, 306)
    延迟 (time)
    dm.LeftDoubleClick ()
    延迟 (time)
 
.如果真结束
 
.如果真 (位置变量 = “右2)
    延迟 (time)
    dm.MoveTo (567, 306)
    延迟 (time)
    dm.LeftDoubleClick ()
    延迟 (time)
 
.如果真结束
 
.如果真 (位置变量 = “单”)
    延迟 (time)
    dm.KeyPress (13)
 
.如果真结束

发布日期:

所属分类: 易语言 标签: