易语言教程流程控制(计次循环首)

一、官方文档

调用格式: 〈无返回值〉 计次循环首 (整数型 循环次数,[整数型变量 已循环次数记录变量]) - 系统核心支持库->流程控制
英文名称:counter
执行本命令将把循环体内的命令重复执行指定的次数。提供的整数参数值决定将重复执行的次数。本命令为初级命令。
参数<1>的名称为“循环次数”,类型为“整数型(int)”。本数值指定执行计次循环体内所有命令的次数,必须大于等于零。
参数<2>的名称为“已循环次数记录变量”,类型为“整数型(int)”,可以被省略,提供参数数据时只能提供变量。本数值型变量用作记录当前循环首已经被进入过的次数(从 1 开始),程序可以直接取用此变量中的值。

操作系统需求: Windows、Linux、Unix

对应命令:
调用格式: 〈无返回值〉 计次循环尾 () - 系统核心支持库->流程控制
英文名称:CounterLoop
本命令已经被隐藏。
如果计次循环的循环次数未到,执行本命令将返回到对应的“计次循环首”命令处继续进行循环,否则将顺序执行下一条命令退出本计次循环。本命令为初级命令。

操作系统需求: Windows、Linux、Unix

二、视频举例源码:

方法1
.版本 2

.子程序 例1
.局部变量 n, 整数型

画板1.清除 (, , , )
.计次循环首 (9, n)
' 画板1.写出 (到文本 (n) + #换行符)
' 画板1.写文本行 (n)
画板1.滚动写行 (n)
.计次循环尾 ()
方法2
.版本 2

.子程序 例2
.局部变量 i, 整数型
.局部变量 输出内容, 文本型

画板1.清除 (, , , )
.计次循环首 (9, i)
输出内容 = 输出内容 + “☆”
画板1.滚动写行 (输出内容)
.计次循环尾 ()
方法3
.版本 2

.子程序 例3
.局部变量 m, 整数型

编辑框1.内容 = “”
.计次循环首 (9, m)
.计次循环首 (m, )
编辑框1.加入文本 (“☆”)
.计次循环尾 ()
编辑框1.加入文本 (#换行符)
.计次循环尾 ()
方法4
.版本 2

.子程序 例4
.局部变量 m, 整数型

编辑框1.内容 = “”
.计次循环首 (9, m)
.计次循环首 (10 - m, )
编辑框1.加入文本 (“☆”)
.计次循环尾 ()
编辑框1.加入文本 (#换行符)
.计次循环尾 ()
方法5
.版本 2

.子程序 例5
.局部变量 n, 整数型

编辑框1.内容 = “”
.计次循环首 (9, n)
.计次循环首 (10 - n, )
编辑框1.加入文本 (字符 (#空格键))
.计次循环尾 ()
.计次循环首 (n, )
编辑框1.加入文本 (“▲”)
.计次循环尾 ()
编辑框1.加入文本 (#换行符)
.计次循环尾 ()
方法6
.版本 2

.子程序 例子6
.局部变量 n, 整数型

编辑框1.内容 = “”
.计次循环首 (9, n)
.计次循环首 (n, )
编辑框1.加入文本 (字符 (#空格键))
.计次循环尾 ()
.计次循环首 (10 - n, )
编辑框1.加入文本 (“▲”)
.计次循环尾 ()
编辑框1.加入文本 (#换行符)
.计次循环尾 ()


发布日期:

所属分类: 易语言 标签: