易语言经典算法采用循环验证哥德巴赫猜想

验证哥德巴赫猜想源码

.版本 2
 
.子程序 _计算图形按钮_被单击
.局部变量 标甲, 整数型
.局部变量 标乙, 整数型
.局部变量 标丙, 整数型
.局部变量 结果, 文本型
 
结果编辑框.内容 = “”  ' 清空
结果 = “”  ' 清空
给定偶数 = 到数值 (偶数编辑框.内容)
.判断开始 (到数值 (偶数编辑框.内容)1000 或 到数值 (偶数编辑框.内容)20 或 到数值 (偶数编辑框.内容)0)
    信息框 (“输入错误!”, 0, “输入错误:)
.判断 (给定偶数 = 2)
    ' 2可以表示成1+1
    结果编辑框.内容 = “2=1+1”
.判断 (给定偶数 = 4)
    ' 4可以表示成1+3
    结果编辑框.内容 = “4=1+3”
.默认
    .变量循环首 (3, 给定偶数 ÷ 2, 2, 标甲)
        .变量循环首 (2, 求平方根 (标甲), 1, 标乙)
            .如果 (标甲 % 标乙 = 0)
                ' 如果模为0,则跳出
                跳出循环 ()
            .否则
 
            .如果结束
 
        .变量循环尾 ()
        .如果 (标乙 > 求平方根 (标甲))
            标丙 = 给定偶数 - 标甲
        .否则
            ' 如果小于则退出循环
            跳出循环 ()
        .如果结束
        .变量循环首 (2, 求平方根 (标丙), 1, 标乙)
            .如果 (标丙 % 标乙 = 0)
                ' 如果模为0,则跳出
                跳出循环 ()
            .否则
 
            .如果结束
 
        .变量循环尾 ()
        .如果 (标乙 > 求平方根 (标丙))
            ' 确认分解的两个素数
            结果 = 结果 + 到文本 (标甲) + “+” + 到文本 (标丙) + “或”
        .否则
 
        .如果结束
 
    .变量循环尾 ()
    结果 = 到文本 (给定偶数) + “=” + 结果
    结果 = 取文本左边 (结果, 取文本长度 (结果)2)  ' 去掉最后一个或
    结果编辑框.内容 = 结果

发布日期:

所属分类: 易语言 标签: