易语言乐玩插件字库建立Ocr识别坐标

乐玩插件字库建立Ocr识别坐标模块源码:

.版本 2

.子程序 SetDict, 整数型, 公开
.参数 index
.参数 file, 文本型
.参数 pwd, 文本型

返回 (obj.数值方法 (“SetDict”, index, file, pwd))

.子程序 UseDict, 整数型, 公开
.参数 index

返回 (obj.数值方法 (“UseDict”, index))

.子程序 Ocr, 文本型, 公开, 返回识别到的字符串
.参数 x1
.参数 y1
.参数 x2
.参数 y2
.参数 color_format, 文本型
.参数 sim, 小数型
.参数 linesign, 文本型
.参数 isbackcolor

返回 (obj.文本方法 (“Ocr”, x1, y1, x2, y2, color_format, sim, linesign, isbackcolor))

.子程序 GetWindowTitle, 文本型, 公开
.参数 hwnd
.参数 flag

返回 (obj.文本方法 (“GetWindowTitle”, hwnd, flag))

.子程序 SetWindowText, 整数型, 公开, 0:失败,1:成功
.参数 hwnd
.参数 title, 文本型

返回 (obj.数值方法 (“SetWindowText”, hwnd, title))

乐玩识字OCR调用源码:

.版本 2
.支持库 spec
.支持库 EThread
 
.子程序 _按钮17_被单击
 
时钟2.时钟周期 = 1000
 
.子程序 识别坐标
.局部变量 ss, 文本型
.局部变量 sss, 文本型
 
ss = l.Ocr (676, 146, 697, 160, “00FF00-000000”, 1, “”, 0)
sss = l.Ocr (702, 145, 720, 161, “00FF00-000000”, 1, “”, 0)
调试输出 (ss)
 
' 标题 = ss + “/” + sss
l.SetWindowText (hwnd, ss + “/” + sss)
 
.子程序 _时钟2_周期事件
 
启动线程 (&识别坐标, , )
 
.子程序 _按钮18_被单击
 
时钟2.时钟周期 = 0
l.SetWindowText (hwnd, game_title)

教程下载:

链接:https://pan.baidu.com/s/1Z-GwQ84X7iccpK3NngsPZQ

提取码:加QQ群:521068947 群文件下载


发布日期:

所属分类: 易语言 标签: