乐玩插件多线程后台绑定-方法2

乐玩插件多线程绑定源码:

.版本 2
.支持库 spec
.支持库 EThread
 
.子程序 多线程绑定
.局部变量 m, 整数型
.局部变量 lww, lwcom
.局部变量 游戏句柄, 文本型
 
' 1、获取游戏窗口句柄
游戏句柄 = lww.EnumWindow (“剑侠情缘·网络版”, “Sword3 Class”, “gamefree.exe”, 0, 0, 0, 0)
调试输出 (游戏句柄)
hwnd = 分割文本 (游戏句柄, “,”, )
重定义数组 (乐玩, 假, 取数组成员数 (hwnd))
.计次循环首 (取数组成员数 (hwnd), m)
    ' 有几个游戏就得创建就几个乐玩对象
    乐玩 [m].创建 ()
    ' 设置全局路径
    ' 设置字库
    ' 屏蔽弹窗错误
    ' 获取句柄
    ' 绑定游戏
    调试输出 (hwnd [m])
    编辑框1.加入文本 (hwnd [m] + #换行符)
    .判断开始 (乐玩 [m].BindWindow (到整数 (hwnd [m]), 4, 1, 1, 0, 0) = 1)
        ' 降低CPU
        乐玩 [m].DownCpu (60)
        ' 启动线程
        启动线程 (&主线程, m, )
    .默认
 
    .判断结束
 
.计次循环尾 ()
.子程序 主线程
.参数 d
 
' 这里就是游戏辅助的环节
跑路 (d)
对话 (d)
打怪 (d)
乐玩 [d].UnBindWindow ()
 
.子程序 跑路
.参数 数组序号
 
.计次循环首 (10, )
    乐玩 [数组序号].KeyPress (114, 1)
    延时 (1000)
.计次循环尾 ()
 
.子程序 对话
.参数 数组序号
 
.计次循环首 (10, )
    乐玩 [数组序号].KeyPress (115, 1)
    延时 (1000)
.计次循环尾 ()
 
.子程序 打怪
.参数 数组序号
 
.计次循环首 (10, )
    乐玩 [数组序号].KeyPress (116, 1)
    延时 (1000)
.计次循环尾 ()

教程下载:

链接:https://pan.baidu.com/s/1Z-GwQ84X7iccpK3NngsPZQ

提取码:加QQ群:521068947 群文件下载


发布日期:

所属分类: 易语言 标签: