511遇见易语言多线程大漠多线程-8启动线程传递参数-API自定义数据

L-8线程传参自定义数据(API)

• 1、RtlMoveMemory
• 复制内存.RtlMoveMemory是重叠复制。
• 2、lstrcpyn
• lstrcpyn该函数把第二个参数指定的字符串复制到第一个参数指定的字符串,第三个参数指定复制的长度
• 3、LocalSize
• 返回本地内存块大小
课程源码:

.子程序 账号登陆
.参数 账号, 文本型
.参数 密码, 文本型
.参数 验证码, 整数型
.局部变量 d, 自定义, 静态
.局部变量 指针, 整数型
 
d.a = 账号
d.b = 密码
d.c = 验证码
指针 = lstrcpyn (d, d, 0)
长度 = LocalSize (指针)
 
启动线程 (&子程序1, 指针, 线程句柄)
 
.子程序 子程序1
.参数 参数, 整数型
.局部变量 e, 自定义
 
' 作为复制内存,特别容易出错,出错的原因就是len长度
RtlMoveMemory (e, 参数, 长度)
 
信息框 (“账号:” + e.a + #换行符 + “密码:” + e.b + #换行符 + “验证码:” + 到文本 (e.c), 0, , )
 
 
.子程序 __启动窗口_将被销毁
 
关闭线程句柄 (线程句柄)


发布日期:

所属分类: 易语言 标签: