511遇见易语言多线程大漠多线程-6线程传参内存地址

L-6-线程传参-封装内存指针

• 1、字节集_到指针
• 2、内存指针_到字节集
• 3、启动线程(,,)
课程源码:

.局部变量 局_字节集, 字节集
.局部变量 a, 整数型
 
局_字节集 = 到字节集 (编辑框1.内容)
a = 字节集_到指针 (局_字节集)
 
启动线程 (&子程序1, a, )
 
 
.子程序 子程序1
.参数 参_整数, 整数型
.局部变量 局_文本, 文本型
 
局_文本 = 内存指针_到字节集 (参_整数)
 
信息框 (局_文本, 0, , )
 
 
.子程序 字节集_到指针, 整数型, 公开
.参数 参_字节集, 字节集
.局部变量 局_长度, 整数型
.局部变量 局_指针, 整数型
 
局_长度 = 取字节集长度 (参_字节集)4  ' 预留4
局_指针 = 申请内存 (局_长度, )
写到内存 (到字节集 (局_长度) + 参_字节集, 局_指针, 局_长度)
返回 (局_指针)
 
 
.子程序 内存指针_到字节集, 文本型, 公开
.参数 参_指针, 整数型
.局部变量 局字节集, 字节集
 
局字节集 = 指针到字节集 (参_指针 + 4, 取字节集数据 (指针到字节集 (参_指针, 4), 3, ) - 4)
释放内存 (参_指针)
返回 (到文本 (局字节集))


发布日期:

所属分类: 易语言 标签: