易语言GetLocalTime获取时间毫秒

511遇见

GetLocalTime

它就一个参数:系统时间格式,这里选择了传址,把获取的系统时间的内存地址返回,它的数据类型是SYSTEMTIME

511遇见

.版本 2
 
.DLL命令 系统时间到毫秒, 整数型, "kernel32", "GetLocalTime", , ,
    .参数 系统时间格式, SYSTEMTIME, 传址

数据类型SYSTEMTIME

511遇见

.版本 2
 
.数据类型 SYSTEMTIME, , , SYSTEMTIME
    .成员 wYear, 短整数型, , , wYear
    .成员 wMonth, 短整数型, , , wMonth
    .成员 wDayOfWeek, 短整数型, , , wDayOfWeek
    .成员 wDay, 短整数型, , , wDay
    .成员 wHour, 短整数型, , , wHour
    .成员 wMinute, 短整数型, , , wMinute
    .成员 wSecond, 短整数型, , , wSecond
    .成员 wMilliseconds, 短整数型, , , wMilliseconds

获取时间

可以直接在时钟事件里写获取时间
首先声明一个变量t,t的数据格式是SYSTEMTIME

511遇见

.版本 2
 
.子程序 _时钟1_周期事件
.局部变量 t, SYSTEMTIME
.局部变量 y, 文本型, , , 年
.局部变量 m, 文本型, , , 月
.局部变量 d, 文本型, , , 日
.局部变量 h, 文本型, , , 时
.局部变量 mm, 文本型, , , 分
.局部变量 s, 文本型, , , 秒
.局部变量 ms, 文本型, , , 毫秒
 
系统时间到毫秒 (t)
y = 到文本 (t.wYear)
m = 到文本 (t.wMonth)
.如果真 (到整数 (m) < 10)
    m = “0” + m
.如果真结束
d = 到文本 (t.wDay)
.如果真 (到整数 (y) < 10)
    d = “0” + d
.如果真结束
h = 到文本 (t.wHour)
.如果真 (到整数 (h) < 10)
    h = “0” + h
.如果真结束
m = 到文本 (t.wMinute)
.如果真 (到整数 (m) < 10)
    m = “0” + m
.如果真结束
s = 到文本 (t.wSecond)
.如果真 (到整数 (s) < 10)
    s = “0” + s
.如果真结束
ms = 到文本 (t.wMilliseconds)
.如果真 (到整数 (ms) < 10)
    ms = “0” + ms
.如果真结束
.如果真 (到整数 (ms) > 10 且 到整数 (ms) < 100)
    ms = “0” + ms
.如果真结束
编辑框1.内容 = y + m + d + h + mm + s + ms

发布日期:

所属分类: 易语言 标签: