易语言StrReverse反向顺序输出任意字符串

实现步骤

1、易语言窗口放置一个脚本组件
2、定义脚本语言:脚本组件.语言 = “VBScript”
3、调用脚本计算方法:脚本组件.计算表达式 (“StrReverse(” + #引号 + 输入字符串 + #引号 + “)”)

源码封装:

.版本 2
.支持库 script
 
.子程序 反向字符串, 文本型
.参数 输入字符串, 文本型
.局部变量 返回文本, 文本型
 
脚本组件.语言 = “VBScript”
 
.如果真 (取文本长度 (输入字符串)0)
    返回 (“”)
.如果真结束
返回文本 = 脚本组件.计算表达式 (“StrReverse(” + #引号 + 输入字符串 + #引号 + “))
返回 (返回文本)

调用示范

反向字符串 (“123456789”)
输出:
开始运行被调试程序
* “987654321”


发布日期:

所属分类: 易语言 标签: