易语言教程取所有配置节名和配置项名

.版本 2
.支持库 spec

.程序集 窗口程序集_启动窗口

.子程序 _按钮1_被单击
.局部变量 序号, 整数型

.如果 (文件是否存在 (取运行目录 () + “\number.ini”) = 真)
序号 = 到整数 (读配置项 (取运行目录 () + “\number.ini”, “保存序号”, “序号”, ))
写配置项 (取运行目录 () + “\song.ini”, “歌曲”, 到文本 (序号), 编辑框1.内容)
序号 = 序号 + 1
写配置项 (取运行目录 () + “\number.ini”, “保存序号”, “序号”, 到文本 (序号))

.否则
写配置项 (取运行目录 () + “\number.ini”, “保存序号”, “序号”, 到文本 (序号))
序号 = 到整数 (读配置项 (取运行目录 () + “\number.ini”, “保存序号”, “序号”, ))
写配置项 (取运行目录 () + “\song.ini”, “歌曲”, 到文本 (序号), 编辑框1.内容)
序号 = 序号 + 1
写配置项 (取运行目录 () + “\number.ini”, “保存序号”, “序号”, 到文本 (序号))
.如果结束

.子程序 _按钮2_被单击
.局部变量 a, 文本型, , "0"
.局部变量 b, 文本型, , "0"
.局部变量 i, 整数型

文件_取配置节名数组 (取运行目录 () + “\song.ini”, a)
调试输出 (a)
.计次循环首 (取数组成员数 (a), i)
文件_取配置项名数组1 (取运行目录 () + “\song.ini”, a [i], b)
调试输出 (a [i], b)
.计次循环尾 ()

.子程序 _按钮3_被单击
.局部变量 节名数组, 文本型, , "0"
.局部变量 i, 整数型

列表框1.清空 ()
节名数组 = 取配置节名 (取运行目录 () + “\song.ini”)
.如果 (取数组成员数 (节名数组) > 0)
.计次循环首 (取数组成员数 (节名数组), i)
列表框1.加入项目 (节名数组 [i], )
.计次循环尾 ()
.否则

.如果结束

.子程序 _按钮4_被单击, , , 取配置节名-2
.局部变量 歌曲文本, 文本型
.局部变量 歌曲文本数组, 文本型, , "0"
.局部变量 a, 整数型
.局部变量 i, 整数型
.局部变量 b, 整数型

列表框2.清空 ()
歌曲文本 = 到文本 (读入文件 (取运行目录 () + “\song.ini”))
歌曲文本数组 = 分割文本 (歌曲文本, #换行符, )
a = 取数组成员数 (歌曲文本数组)
.计次循环首 (a, i)
b = 寻找文本 (歌曲文本数组 [i], “=”, , 假)
.如果真 (取文本左边 (歌曲文本数组 [i], 1) = “[” 且 取文本右边 (歌曲文本数组 [i], 1) = “]”)
列表框2.加入项目 (子文本替换 (子文本替换 (歌曲文本数组 [i], “[”, “”, , , 真), “]”, “”, , , 真), )
.如果真结束

.计次循环尾 ()

.子程序 _按钮5_被单击, , , 取配置项名及数据
.局部变量 歌曲文本, 文本型
.局部变量 歌曲文本数组, 文本型, , "0"
.局部变量 a, 整数型
.局部变量 i, 整数型
.局部变量 b, 整数型

列表框2.清空 ()
列表框1.清空 ()
歌曲文本 = 到文本 (读入文件 (取运行目录 () + “\song.ini”))
歌曲文本数组 = 分割文本 (歌曲文本, #换行符, )
a = 取数组成员数 (歌曲文本数组)
.计次循环首 (a, i)
b = 寻找文本 (歌曲文本数组 [i], “=”, , 假)
.如果真 (b ≠ -1)
列表框2.加入项目 (取文本左边 (歌曲文本数组 [i], b - 1), )
' 列表框1.加入项目 (取文本右边 (歌曲文本数组 [i], 取文本长度 (歌曲文本数组 [i]) - 倒找文本 (歌曲文本数组 [i], “=”, , 假)), )
列表框1.加入项目 (取文本右边 (歌曲文本数组 [i], 取文本长度 (歌曲文本数组 [i]) - b), )
.如果真结束

.计次循环尾 ()


发布日期:

所属分类: 易语言 标签: