易语言教程数组插入成员

文章目录[隐藏]

官方文档

调用格式: 〈无返回值〉 插入成员 (通用型变量数组 欲插入成员的数组变量,整数型 欲插入的位置,通用型数组/非数组 欲插入的成员数据) - 系统核心支持库->数组操作
英文名称:InsElement
将数据插入到指定数组变量的指定位置,并通过重新定义数组维数自动增加其成员数目。数组变量如为多维数组,插入完毕后将被转换为单维数组。本命令为初级命令。
参数<1>的名称为“欲插入成员的数组变量”,类型为“通用型(all)”,提供参数数据时只能提供变量数组。
参数<2>的名称为“欲插入的位置”,类型为“整数型(int)”。位置值从 1 开始,如果小于 1 或大于第一个参数所指定数组变量的成员数目 + 1,将不会插入任何数据。
参数<3>的名称为“欲插入的成员数据”,类型为“通用型(all)”,提供参数数据时可以同时提供数组或非数组数据。参数值所指定成员数据的数据类型必须能够与第一个参数所指定的数组变量相匹配。

操作系统需求: Windows、Linux、Unix

教程源码

.版本 2
.支持库 spec

.程序集 窗口程序集_启动窗口
.程序集变量 数组, 文本型, , "2"

.子程序 __启动窗口_创建完毕

' 插入成员(),参数插入的位置必须大于等于 1
' 如果插入的位置大于数组成员数+1,命令无效,但可以运行,并不报错
数组 [1] = “1”
数组 [2] = “2”

.子程序 _按钮1_被单击, , , 插入成员-1
.局部变量 数组成员数, 整数型

数组成员数 = 取数组成员数 (数组)
调试输出 (数组成员数)
插入成员 (数组, 3, “2032”)
' 加入成员 (数组, “2017”)
数组成员数 = 取数组成员数 (数组)
调试输出 (数组成员数)
调试输出 (数组 [数组成员数])

.子程序 _按钮2_被单击, , , 插入成员-2
.局部变量 a, 文本型, 静态, "0"
.局部变量 n, 整数型

插入成员 (a, 1, “我是第” + 到文本 (取数组成员数 (a) + 1) + “个成员”)

编辑框1.内容 = “数组成员数当前是: ” + 到文本 (取数组成员数 (a)) + “个”

.计次循环首 (取数组成员数 (a), n)
编辑框1.内容 = 编辑框1.内容 + #换行符 + “数组的第” + 到文本 (n) + “个成员的值: ” + a [n]
.计次循环尾 ()


发布日期:

所属分类: 易语言 标签: